aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-10 14:16:23 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-11 18:38:42 +0200
commit479adb0929f8afbd1935a0d71832df1e2cea18b2 (patch)
tree626aed63cb69592d5851c7daaeccebd25f544b91 /target/linux/ramips/image/Makefile
parent9faf9f8f23f43300bfb892abe6513ead30374e20 (diff)
downloadupstream-479adb0929f8afbd1935a0d71832df1e2cea18b2.tar.gz
upstream-479adb0929f8afbd1935a0d71832df1e2cea18b2.tar.bz2
upstream-479adb0929f8afbd1935a0d71832df1e2cea18b2.zip
ramips: consolidate recipes with uimage_padhdr
There are already two very similar recipes using uimage_padhdr in ramips target, and a third one is about to be added. Make the recipe more generic, so redefinitions are not necessary anymore. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Bjørn Mork <bjorn@mork.no> [Zyxel WAP6805]
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 93ce59e262..3ee9828a64 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -51,11 +51,6 @@ define Build/elx-header
rm -rf $(KDIR)/tmp/$(DEVICE_NAME).header
endef
-define Build/fonfxcimage
- uimage_padhdr -i $@ -o $@.new
- mv $@.new $@
-endef
-
define Build/jcg-header
$(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
$(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \
@@ -151,6 +146,11 @@ define Build/trx
-a 4 -f $(IMAGE_ROOTFS)
endef
+define Build/uimage-padhdr
+ uimage_padhdr $(if $(1),-l $(1)) -i $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/umedia-header
fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
endef