aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/image/Makefile10
-rw-r--r--target/linux/ramips/image/mt7620.mk4
-rw-r--r--target/linux/ramips/image/mt7621.mk7
3 files changed, 8 insertions, 13 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 93ce59e262..3ee9828a64 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -51,11 +51,6 @@ define Build/elx-header
rm -rf $(KDIR)/tmp/$(DEVICE_NAME).header
endef
-define Build/fonfxcimage
- uimage_padhdr -i $@ -o $@.new
- mv $@.new $@
-endef
-
define Build/jcg-header
$(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
$(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \
@@ -151,6 +146,11 @@ define Build/trx
-a 4 -f $(IMAGE_ROOTFS)
endef
+define Build/uimage-padhdr
+ uimage_padhdr $(if $(1),-l $(1)) -i $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/umedia-header
fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
endef
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index df3f050048..34e2e42c33 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -400,8 +400,8 @@ define Device/fon_fon2601
DEVICE_VENDOR := Fon
DEVICE_MODEL := FON2601
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
- KERNEL_INITRAMFS := $$(KERNEL) | fonfxcimage
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | fonfxcimage | \
+ KERNEL_INITRAMFS := $$(KERNEL) | uimage-padhdr
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | uimage-padhdr | \
pad-rootfs | append-metadata | check-size
endef
TARGET_DEVICES += fon_fon2601
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 0215683671..25de2fa597 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -81,11 +81,6 @@ define Build/iodata-mstc-header
)
endef
-define Build/mitrastarimage
- uimage_padhdr -l 160 -i $@ -o $@.new
- mv $@.new $@
-endef
-
define Build/ubnt-erx-factory-image
if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
echo '21001:7' > $(1).compat; \
@@ -1146,7 +1141,7 @@ define Device/zyxel_wap6805
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := WAP6805
DEVICE_PACKAGES := kmod-mt7603 wpad-basic kmod-mt7621-qtn-rgmii
- KERNEL := $(KERNEL_DTB) | uImage lzma | mitrastarimage
+ KERNEL := $(KERNEL_DTB) | uImage lzma | uimage-padhdr 160
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
TARGET_DEVICES += zyxel_wap6805