aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-15 20:08:22 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-16 13:39:44 +0200
commit95a05b12d74a50f020bc7728a9541c4f181284ea (patch)
tree6277b6349cdb580629d035eb9fd8b6a8780c0ba9 /target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi
parenta79f55e7e03543afa03c473aebc7e29c49062727 (diff)
downloadupstream-95a05b12d74a50f020bc7728a9541c4f181284ea.tar.gz
upstream-95a05b12d74a50f020bc7728a9541c4f181284ea.tar.bz2
upstream-95a05b12d74a50f020bc7728a9541c4f181284ea.zip
ramips: provide common definition for ELECOM WRC GS devices
Add a common definition for ELECOM WRC "GS" devices to mt7621.mk to not repeat the same assignments five times. To keep the naming consistent, slightly rename the DTSI and the factory image recipe as well. Note that elecom_wrc-1167ghbk2-s uses a slightly different build recipe for the factory image, so we keep it separate. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: INAGAKI Hiroshi <musashino.open@gmail.com> [WRC-1750GSV]
Diffstat (limited to 'target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi')
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi199
1 files changed, 199 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi b/target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi
new file mode 100644
index 0000000000..c28ba7d973
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi
@@ -0,0 +1,199 @@
+// SPDX-License-Identifier: GPL-2.0
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ aliases {
+ led-boot = &led_power_green;
+ led-failsafe = &led_power_green;
+ led-running = &led_power_green;
+ led-upgrade = &led_power_green;
+ label-mac-device = &wan;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power_green: power_green {
+ label = "wrc-gst:green:power";
+ gpios = <&gpio 7 GPIO_ACTIVE_HIGH>;
+ };
+
+ power_blue {
+ label = "wrc-gst:blue:power";
+ gpios = <&gpio 8 GPIO_ACTIVE_HIGH>;
+ };
+
+ wps {
+ label = "wrc-gst:red:wps";
+ gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+ };
+
+ power_red {
+ label = "wrc-gst:red:power";
+ gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ client {
+ label = "client";
+ gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ linux,input-type = <EV_SW>;
+ };
+
+ ap {
+ label = "ap";
+ gpios = <&gpio 42 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ linux,input-type = <EV_SW>;
+ };
+
+ extender {
+ label = "extender";
+ gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ linux,input-type = <EV_SW>;
+ };
+
+ router {
+ label = "router";
+ gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ linux,input-type = <EV_SW>;
+ };
+ };
+};
+
+&gmac0 {
+ mtd-mac-address = <&factory 0xe000>;
+};
+
+&switch0 {
+ ports {
+ wan: port@0 {
+ status = "okay";
+ label = "wan";
+ mtd-mac-address = <&factory 0xe006>;
+ };
+
+ port@1 {
+ status = "okay";
+ label = "lan4";
+ };
+
+ port@2 {
+ status = "okay";
+ label = "lan3";
+ };
+
+ port@3 {
+ status = "okay";
+ label = "lan2";
+ };
+
+ port@4 {
+ status = "okay";
+ label = "lan1";
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions: partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "uart3", "jtag", "wdt", "sdhci";
+ function = "gpio";
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ ieee80211-freq-limit = <2400000 2500000>;
+
+ led {
+ led-sources = <0>;
+ led-active-low;
+ };
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+
+ led {
+ led-sources = <0>;
+ led-active-low;
+ };
+ };
+};
+
+&xhci {
+ status = "disabled";
+};