aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-1750gs.dts2
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-1750gsv.dts2
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-1900gst.dts2
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-2533gst.dts2
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-2533gst2.dts2
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi (renamed from target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi)0
-rw-r--r--target/linux/ramips/image/mt7621.mk49
7 files changed, 24 insertions, 35 deletions
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-1750gs.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-1750gs.dts
index 46d4c1a708..d96fe0cfb5 100644
--- a/target/linux/ramips/dts/mt7621_elecom_wrc-1750gs.dts
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-1750gs.dts
@@ -1,7 +1,7 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;
-#include "mt7621_elecom_wrc-gst.dtsi"
+#include "mt7621_elecom_wrc-gs.dtsi"
/ {
compatible = "elecom,wrc-1750gs", "mediatek,mt7621-soc";
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-1750gsv.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-1750gsv.dts
index 6f2054b076..34631b5ce5 100644
--- a/target/linux/ramips/dts/mt7621_elecom_wrc-1750gsv.dts
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-1750gsv.dts
@@ -1,7 +1,7 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;
-#include "mt7621_elecom_wrc-gst.dtsi"
+#include "mt7621_elecom_wrc-gs.dtsi"
/ {
compatible = "elecom,wrc-1750gsv", "mediatek,mt7621-soc";
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-1900gst.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-1900gst.dts
index 4b99cee31e..c8e6d9c3c9 100644
--- a/target/linux/ramips/dts/mt7621_elecom_wrc-1900gst.dts
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-1900gst.dts
@@ -1,7 +1,7 @@
// SPDX-License-Identifier: GPL-2.0
/dts-v1/;
-#include "mt7621_elecom_wrc-gst.dtsi"
+#include "mt7621_elecom_wrc-gs.dtsi"
/ {
compatible = "elecom,wrc-1900gst", "mediatek,mt7621-soc";
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-2533gst.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-2533gst.dts
index 6158cf196a..2c37c96961 100644
--- a/target/linux/ramips/dts/mt7621_elecom_wrc-2533gst.dts
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-2533gst.dts
@@ -1,6 +1,6 @@
/dts-v1/;
-#include "mt7621_elecom_wrc-gst.dtsi"
+#include "mt7621_elecom_wrc-gs.dtsi"
/ {
compatible = "elecom,wrc-2533gst", "mediatek,mt7621-soc";
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-2533gst2.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-2533gst2.dts
index 01f32e9b20..bce06a6b7d 100644
--- a/target/linux/ramips/dts/mt7621_elecom_wrc-2533gst2.dts
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-2533gst2.dts
@@ -1,7 +1,7 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;
-#include "mt7621_elecom_wrc-gst.dtsi"
+#include "mt7621_elecom_wrc-gs.dtsi"
/ {
compatible = "elecom,wrc-2533gst2", "mediatek,mt7621-soc";
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi b/target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi
index c28ba7d973..c28ba7d973 100644
--- a/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-gs.dtsi
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a16900aa8c..229897ffb5 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -7,7 +7,7 @@ include ./common-tp-link.mk
DEFAULT_SOC := mt7621
KERNEL_DTB += -d21
-DEVICE_VARS += UIMAGE_MAGIC
+DEVICE_VARS += UIMAGE_MAGIC ELECOM_HWNAME
# The OEM webinterface expects an kernel with initramfs which has the uImage
# header field ih_name.
@@ -23,7 +23,7 @@ define Build/custom-initramfs-uimage
mv $@.new $@
endef
-define Build/elecom-gst-factory
+define Build/elecom-wrc-gs-factory
$(eval product=$(word 1,$(1)))
$(eval version=$(word 2,$(1)))
( $(STAGING_DIR_HOST)/bin/mkhash md5 $@ | tr -d '\n' ) >> $@
@@ -326,63 +326,52 @@ define Device/elecom_wrc-1167ghbk2-s
endef
TARGET_DEVICES += elecom_wrc-1167ghbk2-s
-define Device/elecom_wrc-1750gs
+define Device/elecom_wrc-gs
$(Device/uimage-lzma-loader)
- IMAGE_SIZE := 11264k
DEVICE_VENDOR := ELECOM
- DEVICE_MODEL := WRC-1750GS
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
- elecom-gst-factory WRC-1750GS 0.00
+ elecom-wrc-gs-factory $$$$(ELECOM_HWNAME) 0.00
DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
endef
+
+define Device/elecom_wrc-1750gs
+ $(Device/elecom_wrc-gs)
+ IMAGE_SIZE := 11264k
+ DEVICE_MODEL := WRC-1750GS
+ ELECOM_HWNAME := WRC-1750GS
+endef
TARGET_DEVICES += elecom_wrc-1750gs
define Device/elecom_wrc-1750gsv
- $(Device/uimage-lzma-loader)
+ $(Device/elecom_wrc-gs)
IMAGE_SIZE := 11264k
- DEVICE_VENDOR := ELECOM
DEVICE_MODEL := WRC-1750GSV
- IMAGES += factory.bin
- IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
- elecom-gst-factory WRC-1750GSV 0.00
- DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+ ELECOM_HWNAME := WRC-1750GSV
endef
TARGET_DEVICES += elecom_wrc-1750gsv
define Device/elecom_wrc-1900gst
- $(Device/uimage-lzma-loader)
+ $(Device/elecom_wrc-gs)
IMAGE_SIZE := 11264k
- DEVICE_VENDOR := ELECOM
DEVICE_MODEL := WRC-1900GST
- IMAGES += factory.bin
- IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
- elecom-gst-factory WRC-1900GST 0.00
- DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+ ELECOM_HWNAME := WRC-1900GST
endef
TARGET_DEVICES += elecom_wrc-1900gst
define Device/elecom_wrc-2533gst
- $(Device/uimage-lzma-loader)
+ $(Device/elecom_wrc-gs)
IMAGE_SIZE := 11264k
- DEVICE_VENDOR := ELECOM
DEVICE_MODEL := WRC-2533GST
- IMAGES += factory.bin
- IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
- elecom-gst-factory WRC-2533GST 0.00
- DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+ ELECOM_HWNAME := WRC-2533GST
endef
TARGET_DEVICES += elecom_wrc-2533gst
define Device/elecom_wrc-2533gst2
- $(Device/uimage-lzma-loader)
+ $(Device/elecom_wrc-gs)
IMAGE_SIZE := 24576k
- DEVICE_VENDOR := ELECOM
DEVICE_MODEL := WRC-2533GST2
- IMAGES += factory.bin
- IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
- elecom-gst-factory WRC-2533GST2 0.00
- DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+ ELECOM_HWNAME := WRC-2533GST2
endef
TARGET_DEVICES += elecom_wrc-2533gst2