aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2019-07-22 12:54:06 +0200
committerPetr Štetiar <ynezz@true.cz>2019-09-20 11:36:27 +0200
commit10c5d3dd5f52e15204b8446068d5fc55e02d2029 (patch)
treed42c2d6244ba01f57a8e3b54008b17e75e0cc9c4 /target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts
parentfde8e2e035f74ed6e21b3aaf8f24a094b1dd9dc4 (diff)
downloadupstream-10c5d3dd5f52e15204b8446068d5fc55e02d2029.tar.gz
upstream-10c5d3dd5f52e15204b8446068d5fc55e02d2029.tar.bz2
upstream-10c5d3dd5f52e15204b8446068d5fc55e02d2029.zip
ramips: mt7621: Add new device AsiaRF AP7621-NV1
SoC: Mediatek MT7621A CPU: 4x 880Mhz Cache: 32 KB I-Cache and 32 KB D-Cach 256 KB L2 Cache (shared by Dual-Core) RAM: DDR3 512MB 16bits BUS FLASH: 16MB Switch: Mediatek Gigabit Switch (2 x LAN, 1 x WAN) POE: (1x PD, 2x PSE) USB: 1x 3.0 PCI: 3x Mini PCIe (3 USB2.0 + 2 x UIM interface) GPS: Quectel L70B SIM: 2 Slots BTN: Reset LED: - Power - Ethernet - Wifi - USB UART: UART is present as Pads with throughholes on the PCB. They are located on left side. 3.3V - RX - GND - TX / 57600-8N1 3.3V is the square pad Installation ------------ The stock image is a modified openwrt and can be overflashed via sysupgrade -F Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com> [merge conflict in mt7621.mk] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts')
-rw-r--r--target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts116
1 files changed, 1 insertions, 115 deletions
diff --git a/target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts b/target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts
index 2e1479d0c6..9926a9bd5a 100644
--- a/target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts
+++ b/target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts
@@ -1,123 +1,9 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "mt7621_asiarf_ap7621.dtsi"
/ {
compatible = "asiarf,ap7621-001", "mediatek,mt7621-soc";
model = "AsiaRF AP7621-001";
-
- chosen {
- bootargs = "console=ttyS0,57600";
- };
-
- keys {
- compatible = "gpio-keys";
-
- reset {
- label = "reset";
- gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
- linux,code = <KEY_RESTART>;
- };
- };
-
- leds {
- compatible = "gpio-leds";
-
- wlan1 {
- label = "ap7621-001:orange:wlan1";
- gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
- };
-
- wlan0 {
- label = "ap7621-001:orange:wlan0";
- gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
- };
- };
-};
-
-&sdhci {
- status = "okay";
-};
-
-&spi0 {
- status = "okay";
-
- flash@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <40000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x30000>;
- read-only;
- };
-
- partition@30000 {
- label = "u-boot-env";
- reg = <0x30000 0x2000>;
- };
-
- partition@32000 {
- label = "2860";
- reg = <0x32000 0x4000>;
- };
-
- partition@36000 {
- label = "rtdev";
- reg = <0x36000 0x2000>;
- };
-
- partition@38000 {
- label = "Reserve";
- reg = <0x38000 0x8000>;
- };
-
- factory: partition@40000 {
- label = "factory";
- reg = <0x40000 0x10000>;
- read-only;
- };
-
- partition@50000 {
- label = "firmware";
- reg = <0x50000 0xfa0000>;
- compatible = "denx,uimage";
- };
-
- partition@ff0000 {
- label = "nvram";
- reg = <0xff0000 0x10000>;
- read-only;
- };
- };
- };
};
-
-&pcie {
- status = "okay";
-};
-
-&ethernet {
- mtd-mac-address = <&factory 0xe000>;
- mediatek,portmap = "llllw";
-};
-
-&pinctrl {
- state_default: pinctrl0 {
- gpio {
- ralink,group = "wdt", "jtag";
- ralink,function = "gpio";
- };
- };
-};
-