aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts116
-rw-r--r--target/linux/ramips/dts/mt7621_asiarf_ap7621-nv1.dts9
-rw-r--r--target/linux/ramips/dts/mt7621_asiarf_ap7621.dtsi120
-rw-r--r--target/linux/ramips/image/mt7621.mk10
5 files changed, 143 insertions, 115 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 7fc7717ba4..7ab5653d09 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -226,6 +226,9 @@ ramips_setup_interfaces()
asiarf,ap7621-001)
ucidef_add_switch "switch0" "0:lan" "4:wan" "6@eth0"
;;
+ asiarf,ap7621-nv1)
+ ucidef_add_switch "switch0" "0:wan" "2:lan" "3:lan" "6@eth0"
+ ;;
asiarf,awapn2403)
ucidef_add_switch "switch0" \
"0:lan" "1:wan" "6@eth0"
diff --git a/target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts b/target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts
index 2e1479d0c6..9926a9bd5a 100644
--- a/target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts
+++ b/target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts
@@ -1,123 +1,9 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "mt7621_asiarf_ap7621.dtsi"
/ {
compatible = "asiarf,ap7621-001", "mediatek,mt7621-soc";
model = "AsiaRF AP7621-001";
-
- chosen {
- bootargs = "console=ttyS0,57600";
- };
-
- keys {
- compatible = "gpio-keys";
-
- reset {
- label = "reset";
- gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
- linux,code = <KEY_RESTART>;
- };
- };
-
- leds {
- compatible = "gpio-leds";
-
- wlan1 {
- label = "ap7621-001:orange:wlan1";
- gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
- };
-
- wlan0 {
- label = "ap7621-001:orange:wlan0";
- gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
- };
- };
-};
-
-&sdhci {
- status = "okay";
-};
-
-&spi0 {
- status = "okay";
-
- flash@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <40000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x30000>;
- read-only;
- };
-
- partition@30000 {
- label = "u-boot-env";
- reg = <0x30000 0x2000>;
- };
-
- partition@32000 {
- label = "2860";
- reg = <0x32000 0x4000>;
- };
-
- partition@36000 {
- label = "rtdev";
- reg = <0x36000 0x2000>;
- };
-
- partition@38000 {
- label = "Reserve";
- reg = <0x38000 0x8000>;
- };
-
- factory: partition@40000 {
- label = "factory";
- reg = <0x40000 0x10000>;
- read-only;
- };
-
- partition@50000 {
- label = "firmware";
- reg = <0x50000 0xfa0000>;
- compatible = "denx,uimage";
- };
-
- partition@ff0000 {
- label = "nvram";
- reg = <0xff0000 0x10000>;
- read-only;
- };
- };
- };
};
-
-&pcie {
- status = "okay";
-};
-
-&ethernet {
- mtd-mac-address = <&factory 0xe000>;
- mediatek,portmap = "llllw";
-};
-
-&pinctrl {
- state_default: pinctrl0 {
- gpio {
- ralink,group = "wdt", "jtag";
- ralink,function = "gpio";
- };
- };
-};
-
diff --git a/target/linux/ramips/dts/mt7621_asiarf_ap7621-nv1.dts b/target/linux/ramips/dts/mt7621_asiarf_ap7621-nv1.dts
new file mode 100644
index 0000000000..ec322d0e08
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_asiarf_ap7621-nv1.dts
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+#include "mt7621_asiarf_ap7621.dtsi"
+
+/ {
+ compatible = "asiarf,ap7621-nv1", "mediatek,mt7621-soc";
+ model = "AsiaRF AP7621-NV1";
+};
diff --git a/target/linux/ramips/dts/mt7621_asiarf_ap7621.dtsi b/target/linux/ramips/dts/mt7621_asiarf_ap7621.dtsi
new file mode 100644
index 0000000000..044b06b3c4
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_asiarf_ap7621.dtsi
@@ -0,0 +1,120 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ wlan1 {
+ label = "ap7621-001:orange:wlan1";
+ gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan0 {
+ label = "ap7621-001:orange:wlan0";
+ gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&sdhci {
+ status = "okay";
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x2000>;
+ };
+
+ partition@32000 {
+ label = "2860";
+ reg = <0x32000 0x4000>;
+ };
+
+ partition@36000 {
+ label = "rtdev";
+ reg = <0x36000 0x2000>;
+ };
+
+ partition@38000 {
+ label = "Reserve";
+ reg = <0x38000 0x8000>;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0xfa0000>;
+ compatible = "denx,uimage";
+ };
+
+ partition@ff0000 {
+ label = "nvram";
+ reg = <0xff0000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0xe000>;
+ mediatek,portmap = "llllw";
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "wdt", "jtag";
+ ralink,function = "gpio";
+ };
+ };
+};
+
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1727f998c8..f098976dfc 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -125,6 +125,16 @@ define Device/asiarf_ap7621-001
endef
TARGET_DEVICES += asiarf_ap7621-001
+define Device/asiarf_ap7621-nv1
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 16000k
+ DEVICE_VENDOR := AsiaRF
+ DEVICE_MODEL := AP7621-NV1
+ DEVICE_PACKAGES := \
+ kmod-sdhci-mt7620 kmod-mt76x2 kmod-usb3
+endef
+TARGET_DEVICES += asiarf_ap7621-nv1
+
define Device/asus_rt-ac57u
MTK_SOC := mt7621
DEVICE_VENDOR := ASUS