aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 02:21:12 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 14:23:52 +0100
commite93626f1f47ec6c1995067c9ed3798ebd468cda3 (patch)
treea35e4f9be1d413ff567062820589c8248f401879 /target/linux/mvebu/image/Makefile
parent0a388b5bf7b5dbc60df94594c77d932bdd95cba6 (diff)
downloadupstream-e93626f1f47ec6c1995067c9ed3798ebd468cda3.tar.gz
upstream-e93626f1f47ec6c1995067c9ed3798ebd468cda3.tar.bz2
upstream-e93626f1f47ec6c1995067c9ed3798ebd468cda3.zip
mvebu: use SOC to derive DEVICE_DTS
This introduces the SOC variable to mvebu target to derive some of the DEVICE_DTS variables based on the SOC prefix and the device definition name. Since DTS names and compatible are inconsistent also in the kernel for this target, the scheme cannot be applied to all devices, though. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 6dd7bde7ae..c08b113b36 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -77,6 +77,7 @@ endef
define Device/Default
PROFILES := Default
+ DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
BOARD_NAME = $$(DEVICE_DTS)
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none