aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 02:21:12 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 14:23:52 +0100
commite93626f1f47ec6c1995067c9ed3798ebd468cda3 (patch)
treea35e4f9be1d413ff567062820589c8248f401879 /target/linux/mvebu/image
parent0a388b5bf7b5dbc60df94594c77d932bdd95cba6 (diff)
downloadupstream-e93626f1f47ec6c1995067c9ed3798ebd468cda3.tar.gz
upstream-e93626f1f47ec6c1995067c9ed3798ebd468cda3.tar.bz2
upstream-e93626f1f47ec6c1995067c9ed3798ebd468cda3.zip
mvebu: use SOC to derive DEVICE_DTS
This introduces the SOC variable to mvebu target to derive some of the DEVICE_DTS variables based on the SOC prefix and the device definition name. Since DTS names and compatible are inconsistent also in the kernel for this target, the scheme cannot be applied to all devices, though. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile1
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk8
-rw-r--r--target/linux/mvebu/image/cortex-a9.mk6
3 files changed, 8 insertions, 7 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 6dd7bde7ae..c08b113b36 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -77,6 +77,7 @@ endef
define Device/Default
PROFILES := Default
+ DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
BOARD_NAME = $$(DEVICE_DTS)
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index e58a3c42b9..73bd61f22e 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -6,7 +6,7 @@ define Device/globalscale_espressobin
DEVICE_ALT0_VENDOR := Marvell
DEVICE_ALT0_MODEL := Armada 3700 Community Board
DEVICE_ALT0_VARIANT := Non-eMMC
- DEVICE_DTS := armada-3720-espressobin
+ SOC := armada-3720
endef
TARGET_DEVICES += globalscale_espressobin
@@ -18,7 +18,7 @@ define Device/globalscale_espressobin-emmc
DEVICE_ALT0_VENDOR := Marvell
DEVICE_ALT0_MODEL := Armada 3700 Community Board
DEVICE_ALT0_VARIANT := eMMC
- DEVICE_DTS := armada-3720-espressobin-emmc
+ SOC := armada-3720
endef
TARGET_DEVICES += globalscale_espressobin-emmc
@@ -30,7 +30,7 @@ define Device/globalscale_espressobin-v7
DEVICE_ALT0_VENDOR := Marvell
DEVICE_ALT0_MODEL := Armada 3700 Community Board
DEVICE_ALT0_VARIANT := V7 Non-eMMC
- DEVICE_DTS := armada-3720-espressobin-v7
+ SOC := armada-3720
endef
TARGET_DEVICES += globalscale_espressobin-v7
@@ -42,7 +42,7 @@ define Device/globalscale_espressobin-v7-emmc
DEVICE_ALT0_VENDOR := Marvell
DEVICE_ALT0_MODEL := Armada 3700 Community Board
DEVICE_ALT0_VARIANT := V7 eMMC
- DEVICE_DTS := armada-3720-espressobin-v7-emmc
+ SOC := armada-3720
endef
TARGET_DEVICES += globalscale_espressobin-v7-emmc
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index 389082e426..79253049c7 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -93,7 +93,7 @@ define Device/plathome_openblocks-ax3-4
DEVICE_VENDOR := Plat'Home
DEVICE_MODEL := OpenBlocks AX3
DEVICE_VARIANT := 4 ports
- DEVICE_DTS := armada-xp-openblocks-ax3-4
+ SOC := armada-xp
SUPPORTED_DEVICES += openblocks-ax3-4
BLOCKSIZE := 128k
PAGESIZE := 1
@@ -193,7 +193,7 @@ define Device/globalscale_mirabox
$(Device/NAND-512K)
DEVICE_VENDOR := Globalscale
DEVICE_MODEL := Mirabox
- DEVICE_DTS := armada-370-mirabox
+ SOC := armada-370
SUPPORTED_DEVICES += mirabox
endef
TARGET_DEVICES += globalscale_mirabox
@@ -212,7 +212,7 @@ define Device/cznic_turris-omnia
IMAGE/$$(IMAGE_PREFIX)-sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip
IMAGE_NAME = $$(2)
- DEVICE_DTS := armada-385-turris-omnia
+ SOC := armada-385
SUPPORTED_DEVICES += armada-385-turris-omnia
endef
TARGET_DEVICES += cznic_turris-omnia