aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-04-08 20:09:35 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-04-13 15:09:09 +0200
commitbb831ca43a0911a78e488b3a354f3c0478068f70 (patch)
treebded7535bdbdb81fb2a6a4502ed7ba9290529f5f /target/linux/mpc85xx
parent84b1257f80ab3265b994c059ab7d531630ac3074 (diff)
downloadupstream-bb831ca43a0911a78e488b3a354f3c0478068f70.tar.gz
upstream-bb831ca43a0911a78e488b3a354f3c0478068f70.tar.bz2
upstream-bb831ca43a0911a78e488b3a354f3c0478068f70.zip
mpc85xx: clean up device package selection
Remove wireless and USB packages from the device-specific package selection as they are already selected by the target itself. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mpc85xx')
-rw-r--r--target/linux/mpc85xx/image/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index 55870764fb..d2c3ae1861 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -48,7 +48,6 @@ ifeq ($(SUBTARGET),generic)
define Device/tl-wdr4900-v1
DEVICE_TITLE := TP-Link TL-WDR4900
- DEVICE_PACKAGES := kmod-ath9k wpad-basic
TPLINK_HWID := 0x49000001
TPLINK_HWREV := 1
TPLINK_FLASHLAYOUT := 16Mppc
@@ -64,7 +63,6 @@ TARGET_DEVICES += tl-wdr4900-v1
define Device/red-15w-rev1
DEVICE_TITLE := Sophos RED 15w Rev.1
- DEVICE_PACKAGES := kmod-usb2
# Original firmware uses a dedicated DTB-partition.
# The bootloader however supports FIT-images.
KERNEL = kernel-bin | gzip | fit gzip $(KDIR)/image-$$(DEVICE_DTS).dtb
@@ -80,7 +78,7 @@ ifeq ($(SUBTARGET),p1020)
define Device/hiveap-330
DEVICE_TITLE := Aerohive HiveAP-330
- DEVICE_PACKAGES := kmod-ath9k wpad-basic kmod-tpm-i2c-atmel
+ DEVICE_PACKAGES := kmod-tpm-i2c-atmel
BLOCKSIZE := 128k
KERNEL_NAME := zImage
KERNEL_SIZE := 8m
@@ -97,7 +95,7 @@ TARGET_DEVICES += hiveap-330
define Device/panda
DEVICE_TITLE := OCEDO Panda
- DEVICE_PACKAGES := kmod-rtc-ds1307 kmod-usb2 uboot-envtools
+ DEVICE_PACKAGES := kmod-rtc-ds1307 uboot-envtools
KERNEL = kernel-bin | gzip | fit gzip $(KDIR)/image-$$(DEVICE_DTS).dtb
PAGESIZE := 2048
SUBPAGESIZE := 512