aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-04-08 20:09:34 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-04-13 15:09:09 +0200
commit84b1257f80ab3265b994c059ab7d531630ac3074 (patch)
treefacda5027ff30ee6255832de3a6c3d74e8d8aa8b /target/linux/mpc85xx
parent68b8d3b0796d202a2d2aa1a9fc781f186e54e8be (diff)
downloadupstream-84b1257f80ab3265b994c059ab7d531630ac3074.tar.gz
upstream-84b1257f80ab3265b994c059ab7d531630ac3074.tar.bz2
upstream-84b1257f80ab3265b994c059ab7d531630ac3074.zip
mpc85xx: remove USB support from kernel
This removes USB support from the compiled kernel. Because of this, the kernel is just small enough for the TP-Link WDR4900 to boot the resulting kernel. This is necessary to support the WDR4900 in the upcoming 19.xx release. In the long run, this should be fixed with a second stage bootloader, as the vendor bootloader only loads the first 2684k bytes. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mpc85xx')
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/mpc85xx/config-4.147
-rw-r--r--target/linux/mpc85xx/config-4.197
3 files changed, 1 insertions, 15 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 370ef81f15..02fdc2f53d 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -22,6 +22,6 @@ include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
- kmod-leds-gpio swconfig kmod-ath9k wpad-basic
+ kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2-fsl
$(eval $(call BuildTarget))
diff --git a/target/linux/mpc85xx/config-4.14 b/target/linux/mpc85xx/config-4.14
index f057e5c910..f2337210d4 100644
--- a/target/linux/mpc85xx/config-4.14
+++ b/target/linux/mpc85xx/config-4.14
@@ -354,13 +354,6 @@ CONFIG_UCC=y
CONFIG_UCC_FAST=y
CONFIG_UCC_GETH=y
# CONFIG_UGETH_TX_ON_DEMAND is not set
-CONFIG_USB=y
-CONFIG_USB_COMMON=y
-CONFIG_USB_EHCI_FSL=y
-CONFIG_USB_EHCI_HCD=y
-# CONFIG_USB_EHCI_HCD_PLATFORM is not set
-CONFIG_USB_EHCI_HCD_PPC_OF=y
-CONFIG_USB_FHCI_HCD=y
CONFIG_USB_SUPPORT=y
CONFIG_VDSO32=y
# CONFIG_VIRT_CPU_ACCOUNTING_NATIVE is not set
diff --git a/target/linux/mpc85xx/config-4.19 b/target/linux/mpc85xx/config-4.19
index c92edcfa37..df4d741c27 100644
--- a/target/linux/mpc85xx/config-4.19
+++ b/target/linux/mpc85xx/config-4.19
@@ -315,13 +315,6 @@ CONFIG_UCC=y
CONFIG_UCC_FAST=y
CONFIG_UCC_GETH=y
# CONFIG_UGETH_TX_ON_DEMAND is not set
-CONFIG_USB=y
-CONFIG_USB_COMMON=y
-CONFIG_USB_EHCI_FSL=y
-CONFIG_USB_EHCI_HCD=y
-# CONFIG_USB_EHCI_HCD_PLATFORM is not set
-CONFIG_USB_EHCI_HCD_PPC_OF=y
-CONFIG_USB_FHCI_HCD=y
CONFIG_USB_SUPPORT=y
CONFIG_VDSO32=y
# CONFIG_VIRT_CPU_ACCOUNTING_NATIVE is not set