aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-08-03 12:52:22 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-19 15:27:15 +0100
commit2c2d77bd3bd4691c5f8f1760b9ef16f96f345255 (patch)
tree4327185141cbed9f6a30fada4e6dafad3ac15ddb /target/linux/layerscape
parenta9075d42d7990af230a08bdbb03c14ae2bf27318 (diff)
downloadupstream-2c2d77bd3bd4691c5f8f1760b9ef16f96f345255.tar.gz
upstream-2c2d77bd3bd4691c5f8f1760b9ef16f96f345255.tar.bz2
upstream-2c2d77bd3bd4691c5f8f1760b9ef16f96f345255.zip
layerscape: add FRWY-LS1046A board support
The LS1046A Freeway board (FRWY) is a high-performance computing, evaluation, and development platform that supports the QorIQ LS1046A architecture processor capable of support more than 32,000 CoreMark performance. The FRWY-LS1046A board supports the QorIQ LS1046A processor, onboard DDR4 memory, multiple Gigabit Ethernet, USB3.0 and M2_Type_E interfaces for Wi-Fi. The FRWY-LS1046A-TP includes the Coral Tensor Flow Processing Unit that offloads AI/ML inferencing from the CPU to provide significant boost for AI/ML applications. The FRWY-LS1046A-TP includes one M.2 TPU module and more modules can easily be added including USB versions of the module to scale the AI/ML performance. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com> [rebase, use AUTORELEASE, fix sorting, add dtb to firmware part] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/layerscape')
-rw-r--r--target/linux/layerscape/base-files/lib/upgrade/platform.sh5
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk41
2 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/layerscape/base-files/lib/upgrade/platform.sh b/target/linux/layerscape/base-files/lib/upgrade/platform.sh
index a8d83de7ea..f9b1e57a43 100644
--- a/target/linux/layerscape/base-files/lib/upgrade/platform.sh
+++ b/target/linux/layerscape/base-files/lib/upgrade/platform.sh
@@ -72,6 +72,7 @@ platform_copy_config() {
fsl,ls1021a-iot-sdboot | \
fsl,ls1021a-twr-sdboot | \
fsl,ls1043a-rdb-sdboot | \
+ fsl,ls1046a-frwy-sdboot | \
fsl,ls1046a-rdb-sdboot | \
fsl,ls1088a-rdb-sdboot)
platform_copy_config_sdboot
@@ -95,6 +96,8 @@ platform_check_image() {
fsl,ls1021a-twr-sdboot | \
fsl,ls1043a-rdb | \
fsl,ls1043a-rdb-sdboot | \
+ fsl,ls1046a-frwy | \
+ fsl,ls1046a-frwy-sdboot | \
fsl,ls1046a-rdb | \
fsl,ls1046a-rdb-sdboot | \
fsl,ls1088a-rdb | \
@@ -125,6 +128,7 @@ platform_do_upgrade() {
fsl,ls1012a-rdb | \
fsl,ls1021a-twr | \
fsl,ls1043a-rdb | \
+ fsl,ls1046a-frwy | \
fsl,ls1046a-rdb | \
fsl,ls1088a-rdb | \
fsl,ls2088a-rdb)
@@ -135,6 +139,7 @@ platform_do_upgrade() {
fsl,ls1021a-iot-sdboot | \
fsl,ls1021a-twr-sdboot | \
fsl,ls1043a-rdb-sdboot | \
+ fsl,ls1046a-frwy-sdboot | \
fsl,ls1046a-rdb-sdboot | \
fsl,ls1088a-rdb-sdboot)
platform_do_upgrade_sdboot "$1"
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index 958faa270e..c037061aa2 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -151,6 +151,47 @@ define Device/fsl_ls1043a-rdb-sdboot
endef
TARGET_DEVICES += fsl_ls1043a-rdb-sdboot
+define Device/fsl_ls1046a-frwy
+ DEVICE_VENDOR := NXP
+ DEVICE_MODEL := FRWY-LS1046A
+ DEVICE_VARIANT := Default
+ DEVICE_PACKAGES += \
+ layerscape-fman \
+ tfa-ls1046a-frwy
+ DEVICE_DTS := freescale/fsl-ls1046a-frwy-sdk
+ IMAGE/firmware.bin := \
+ ls-clean | \
+ ls-append $(1)-bl2.pbl | pad-to 1M | \
+ ls-append $(1)-fip.bin | pad-to 5M | \
+ ls-append $(1)-uboot-env.bin | pad-to 9M | \
+ ls-append fsl_ls1046a-rdb-fman.bin | pad-to 15M | \
+ ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-rootfs | pad-rootfs | check-size
+endef
+TARGET_DEVICES += fsl_ls1046a-frwy
+
+define Device/fsl_ls1046a-frwy-sdboot
+ $(Device/fsl-sdboot)
+ DEVICE_VENDOR := NXP
+ DEVICE_MODEL := FRWY-LS1046A
+ DEVICE_VARIANT := SD Card Boot
+ DEVICE_PACKAGES += \
+ layerscape-fman \
+ tfa-ls1046a-frwy-sdboot
+ DEVICE_DTS := freescale/fsl-ls1046a-frwy-sdk
+ IMAGE/sdcard.img.gz := \
+ ls-clean | \
+ ls-append-sdhead $(1) | pad-to 4K | \
+ ls-append $(1)-bl2.pbl | pad-to 1M | \
+ ls-append $(1)-fip.bin | pad-to 5M | \
+ ls-append $(1)-uboot-env.bin | pad-to 9M | \
+ ls-append fsl_ls1046a-rdb-fman.bin | pad-to 16M | \
+ ls-append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+ append-rootfs | pad-to $(LS_SD_IMAGE_SIZE)M | gzip
+endef
+TARGET_DEVICES += fsl_ls1046a-frwy-sdboot
+
define Device/fsl_ls1046a-rdb
$(Device/fix-sysupgrade)
DEVICE_VENDOR := NXP