aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-12 16:37:29 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-19 15:23:52 +0100
commita9075d42d7990af230a08bdbb03c14ae2bf27318 (patch)
treec4317840f94ff28ad4380158464115d8714d03ff /target/linux/layerscape
parentca6954e2dc3faa32eec54b93bda996c874409675 (diff)
downloadupstream-a9075d42d7990af230a08bdbb03c14ae2bf27318.tar.gz
upstream-a9075d42d7990af230a08bdbb03c14ae2bf27318.tar.bz2
upstream-a9075d42d7990af230a08bdbb03c14ae2bf27318.zip
layerscape: move rework-sdcard-images out of fsl-sdboot
Upcoming devices will not need the migration setup, so let's move it out of the common definition. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/layerscape')
-rw-r--r--target/linux/layerscape/image/armv7.mk3
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk5
2 files changed, 6 insertions, 2 deletions
diff --git a/target/linux/layerscape/image/armv7.mk b/target/linux/layerscape/image/armv7.mk
index 4ab2cec224..da9484764c 100644
--- a/target/linux/layerscape/image/armv7.mk
+++ b/target/linux/layerscape/image/armv7.mk
@@ -21,7 +21,6 @@ define Device/Default
endef
define Device/fsl-sdboot
- $(Device/rework-sdcard-images)
KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
IMAGES := sdcard.img.gz sysupgrade.bin
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
@@ -45,6 +44,7 @@ endef
TARGET_DEVICES += fsl_ls1021a-twr
define Device/fsl_ls1021a-twr-sdboot
+ $(Device/rework-sdcard-images)
$(Device/fsl-sdboot)
DEVICE_VENDOR := NXP
DEVICE_MODEL := TWR-LS1021A
@@ -61,6 +61,7 @@ endef
TARGET_DEVICES += fsl_ls1021a-twr-sdboot
define Device/fsl_ls1021a-iot-sdboot
+ $(Device/rework-sdcard-images)
$(Device/fsl-sdboot)
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1021A-IoT
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index 75d6885c6d..958faa270e 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -20,7 +20,6 @@ define Device/Default
endef
define Device/fsl-sdboot
- $(Device/rework-sdcard-images)
KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
IMAGES := sdcard.img.gz sysupgrade.bin
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
@@ -76,6 +75,7 @@ endef
TARGET_DEVICES += fsl_ls1012a-rdb
define Device/fsl_ls1012a-frwy-sdboot
+ $(Device/rework-sdcard-images)
$(Device/fsl-sdboot)
DEVICE_VENDOR := NXP
DEVICE_MODEL := FRWY-LS1012A
@@ -126,6 +126,7 @@ endef
TARGET_DEVICES += fsl_ls1043a-rdb
define Device/fsl_ls1043a-rdb-sdboot
+ $(Device/rework-sdcard-images)
$(Device/fsl-sdboot)
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1043A-RDB
@@ -176,6 +177,7 @@ endef
TARGET_DEVICES += fsl_ls1046a-rdb
define Device/fsl_ls1046a-rdb-sdboot
+ $(Device/rework-sdcard-images)
$(Device/fsl-sdboot)
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1046A-RDB
@@ -228,6 +230,7 @@ endef
TARGET_DEVICES += fsl_ls1088a-rdb
define Device/fsl_ls1088a-rdb-sdboot
+ $(Device/rework-sdcard-images)
$(Device/fsl-sdboot)
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1088A-RDB