aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/modules.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-09-27 22:44:25 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-27 22:54:19 +0200
commitd8274451cb86021107b5efd99694857f869ae6a1 (patch)
tree943a0b6720dfc760d2f830ca0762a31aa208a68b /target/linux/layerscape/modules.mk
parent7cc2a6c6be4d3dbb3467f184844db282fc30e2e1 (diff)
downloadupstream-d8274451cb86021107b5efd99694857f869ae6a1.tar.gz
upstream-d8274451cb86021107b5efd99694857f869ae6a1.tar.bz2
upstream-d8274451cb86021107b5efd99694857f869ae6a1.zip
layerscape: kmod-ppfe: Fix kernel options
The CONFIG_FSL_PPFE and the CONFIG_FSL_PPFE_UTIL_DISABLED are boolean, so they should be selected with an =y in OpenWrt, otherwise OpenWrt will select them as =m. These options will make pfe.ko being build as a module even if this is boolean. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/layerscape/modules.mk')
-rw-r--r--target/linux/layerscape/modules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/layerscape/modules.mk b/target/linux/layerscape/modules.mk
index 7a368a0d29..5f2d472c95 100644
--- a/target/linux/layerscape/modules.mk
+++ b/target/linux/layerscape/modules.mk
@@ -9,7 +9,8 @@ define KernelPackage/ppfe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Freescale PPFE Driver support
DEPENDS:=@TARGET_layerscape
- KCONFIG:=CONFIG_FSL_PPFE CONFIG_FSL_PPFE_UTIL_DISABLED
+ KCONFIG:=CONFIG_FSL_PPFE=y \
+ CONFIG_FSL_PPFE_UTIL_DISABLED=y
FILES:=$(LINUX_DIR)/drivers/staging/fsl_ppfe/pfe.ko
AUTOLOAD:=$(call AutoLoad,35,pfe)
endef