aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-05-27 11:10:19 +0800
committerPetr Štetiar <ynezz@true.cz>2020-07-11 14:44:22 +0200
commit5ca89036316b15781ed476dc4a7195b791594bce (patch)
tree9649ed2a96388c42c1f45cd56132644b573182af /target/linux/layerscape/image
parenteb24a57b7ff84242bfb717ce947f9d3e1c0518ee (diff)
downloadupstream-5ca89036316b15781ed476dc4a7195b791594bce.tar.gz
upstream-5ca89036316b15781ed476dc4a7195b791594bce.tar.bz2
upstream-5ca89036316b15781ed476dc4a7195b791594bce.zip
layerscape: convert to squashfs rootfs for QSPI NOR boot
There had been an issue in Layerscape QSPI driver for very long time, which made squashfs,jffs2 rootfs not work on QSPI NOR. And the ubifs had been used as a workaround. Now the issue has been fixed. So convert to use squashfs,jffs2 rootfs on QSPI NOR for Layerscape boards (LS1012ARDB/LS1046ARDB/ LS1088ARDB), and update u-boot bootargs for booting. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk22
1 files changed, 5 insertions, 17 deletions
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index ffc8346d24..3ad831b0b1 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -8,8 +8,7 @@
define Device/Default
PROFILES := Default
IMAGES := firmware.bin
- FILESYSTEMS := ubifs
- MKUBIFS_OPTS := -m 1 -e 262016 -c 128
+ FILESYSTEMS := squashfs
KERNEL := kernel-bin | gzip | uImage gzip
KERNEL_LOADADDR := 0x80080000
KERNEL_ENTRY_POINT := 0x80080000
@@ -24,7 +23,6 @@ define Device/ls1012afrdm
kmod-ppfe
DEVICE_DTS := freescale/fsl-ls1012a-frdm
BLOCKSIZE := 256KiB
- FILESYSTEMS := squashfs
IMAGES += sysupgrade.bin
IMAGE/firmware.bin := \
ls-clean | \
@@ -51,9 +49,6 @@ define Device/ls1012ardb
tfa-ls1012ardb \
kmod-ppfe
DEVICE_DTS := freescale/fsl-ls1012a-rdb
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -62,7 +57,7 @@ define Device/ls1012ardb
ls-append pfe.itb | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
+ append-rootfs | pad-rootfs | check-size 67108865
endef
TARGET_DEVICES += ls1012ardb
@@ -101,7 +96,6 @@ define Device/ls1043ardb
tfa-ls1043ardb \
fmc fmc-eth-config
DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
- FILESYSTEMS := squashfs
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -147,9 +141,6 @@ define Device/ls1046ardb
tfa-ls1046ardb \
fmc fmc-eth-config
DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -158,7 +149,7 @@ define Device/ls1046ardb
ls-append $(1)-fman.bin | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
+ append-rootfs | pad-rootfs | check-size 67108865
endef
TARGET_DEVICES += ls1046ardb
@@ -196,9 +187,6 @@ define Device/ls1088ardb
tfa-ls1088ardb \
restool
DEVICE_DTS := freescale/fsl-ls1088a-rdb
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -209,7 +197,7 @@ define Device/ls1088ardb
ls-append $(1)-dpc.dtb | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
+ append-rootfs | pad-rootfs | check-size 67108865
endef
TARGET_DEVICES += ls1088ardb
@@ -249,7 +237,6 @@ define Device/ls2088ardb
tfa-ls2088ardb \
restool
DEVICE_DTS := freescale/fsl-ls2088a-rdb
- FILESYSTEMS := squashfs
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -272,6 +259,7 @@ define Device/traverse-ls1043
KERNEL_INSTALL := 1
FDT_LOADADDR = 0x90000000
FILESYSTEMS := ubifs
+ MKUBIFS_OPTS := -m 1 -e 262016 -c 128
DEVICE_PACKAGES += \
layerscape-fman \
uboot-envtools \