aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-05-27 11:10:19 +0800
committerPetr Štetiar <ynezz@true.cz>2020-07-11 14:44:22 +0200
commit5ca89036316b15781ed476dc4a7195b791594bce (patch)
tree9649ed2a96388c42c1f45cd56132644b573182af
parenteb24a57b7ff84242bfb717ce947f9d3e1c0518ee (diff)
downloadupstream-5ca89036316b15781ed476dc4a7195b791594bce.tar.gz
upstream-5ca89036316b15781ed476dc4a7195b791594bce.tar.bz2
upstream-5ca89036316b15781ed476dc4a7195b791594bce.zip
layerscape: convert to squashfs rootfs for QSPI NOR boot
There had been an issue in Layerscape QSPI driver for very long time, which made squashfs,jffs2 rootfs not work on QSPI NOR. And the ubifs had been used as a workaround. Now the issue has been fixed. So convert to use squashfs,jffs2 rootfs on QSPI NOR for Layerscape boards (LS1012ARDB/LS1046ARDB/ LS1088ARDB), and update u-boot bootargs for booting. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
-rw-r--r--package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt2
-rw-r--r--package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt2
-rw-r--r--package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt2
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk22
4 files changed, 8 insertions, 20 deletions
diff --git a/package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt b/package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt
index 99e61ff119..5acd5406ce 100644
--- a/package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt
+++ b/package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt
@@ -3,6 +3,6 @@ loadaddr=0x81000000
fdt_high=0xffffffffffffffff
initrd_high=0xffffffffffffffff
qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000 1000000;bootm $loadaddr - $fdtaddr
-bootargs=ubi.mtd=8 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.spi:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(pfe),2m(reserved-2),1m(dtb),16m(kernel),32m(ubifs)
+bootargs=root=/dev/mtdblock8 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.spi:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(pfe),2m(reserved-2),1m(dtb),16m(kernel),32m(rootfs)
bootcmd=echo starting openwrt ...;pfe stop;run qspi_boot
bootdelay=3
diff --git a/package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt b/package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt
index 7bc7e2c972..89acac2a82 100644
--- a/package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt
+++ b/package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt
@@ -4,6 +4,6 @@ fdt_high=0xffffffffffffffff
initrd_high=0xffffffffffffffff
hwconfig=fsl_ddr:bank_intlv=auto
qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000 1000000;bootm $loadaddr - $fdtaddr
-bootargs=ubi.mtd=9 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.spi-0:1m(bl2),4m(fip),1m(u-boot-env),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(ubifs)
+bootargs=root=/dev/mtdblock9 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.spi-0:1m(bl2),4m(fip),1m(u-boot-env),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(rootfs)
bootcmd=echo starting openwrt ...;run qspi_boot
bootdelay=3
diff --git a/package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt b/package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt
index 89004d2475..78556f3165 100644
--- a/package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt
+++ b/package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt
@@ -5,6 +5,6 @@ initrd_high=0xffffffffffffffff
hwconfig=fsl_ddr:bank_intlv=auto
mc_init=sf probe 0:0;sf read 80000000 a00000 300000;sf read 80300000 e00000 100000;fsl_mc start mc 80000000 80300000;sf read 80400000 d00000 100000;fsl_mc apply dpl 80400000
qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000 1000000;bootm $loadaddr - $fdtaddr
-bootargs=ubi.mtd=10 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=20c0000.spi-0:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(ubifs)
+bootargs=root=/dev/mtdblock10 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=20c0000.spi-0:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(rootfs)
bootcmd=echo starting openwrt ...;run mc_init;run qspi_boot
bootdelay=3
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index ffc8346d24..3ad831b0b1 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -8,8 +8,7 @@
define Device/Default
PROFILES := Default
IMAGES := firmware.bin
- FILESYSTEMS := ubifs
- MKUBIFS_OPTS := -m 1 -e 262016 -c 128
+ FILESYSTEMS := squashfs
KERNEL := kernel-bin | gzip | uImage gzip
KERNEL_LOADADDR := 0x80080000
KERNEL_ENTRY_POINT := 0x80080000
@@ -24,7 +23,6 @@ define Device/ls1012afrdm
kmod-ppfe
DEVICE_DTS := freescale/fsl-ls1012a-frdm
BLOCKSIZE := 256KiB
- FILESYSTEMS := squashfs
IMAGES += sysupgrade.bin
IMAGE/firmware.bin := \
ls-clean | \
@@ -51,9 +49,6 @@ define Device/ls1012ardb
tfa-ls1012ardb \
kmod-ppfe
DEVICE_DTS := freescale/fsl-ls1012a-rdb
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -62,7 +57,7 @@ define Device/ls1012ardb
ls-append pfe.itb | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
+ append-rootfs | pad-rootfs | check-size 67108865
endef
TARGET_DEVICES += ls1012ardb
@@ -101,7 +96,6 @@ define Device/ls1043ardb
tfa-ls1043ardb \
fmc fmc-eth-config
DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
- FILESYSTEMS := squashfs
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -147,9 +141,6 @@ define Device/ls1046ardb
tfa-ls1046ardb \
fmc fmc-eth-config
DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -158,7 +149,7 @@ define Device/ls1046ardb
ls-append $(1)-fman.bin | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
+ append-rootfs | pad-rootfs | check-size 67108865
endef
TARGET_DEVICES += ls1046ardb
@@ -196,9 +187,6 @@ define Device/ls1088ardb
tfa-ls1088ardb \
restool
DEVICE_DTS := freescale/fsl-ls1088a-rdb
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -209,7 +197,7 @@ define Device/ls1088ardb
ls-append $(1)-dpc.dtb | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
+ append-rootfs | pad-rootfs | check-size 67108865
endef
TARGET_DEVICES += ls1088ardb
@@ -249,7 +237,6 @@ define Device/ls2088ardb
tfa-ls2088ardb \
restool
DEVICE_DTS := freescale/fsl-ls2088a-rdb
- FILESYSTEMS := squashfs
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -272,6 +259,7 @@ define Device/traverse-ls1043
KERNEL_INSTALL := 1
FDT_LOADADDR = 0x90000000
FILESYSTEMS := ubifs
+ MKUBIFS_OPTS := -m 1 -e 262016 -c 128
DEVICE_PACKAGES += \
layerscape-fman \
uboot-envtools \