aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2021-07-21 14:24:52 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-12-29 20:35:57 +0100
commitafd7ec3b57c3ff66f0a8ed250ed468e23cc9cb27 (patch)
treef04ddd1d8010fd47497a976fa90c54bc4e4e5039 /target/linux/kirkwood/image
parent4e46ae1f69b5ff1cf09b2e2eee69a7c38a00202d (diff)
downloadupstream-afd7ec3b57c3ff66f0a8ed250ed468e23cc9cb27.tar.gz
upstream-afd7ec3b57c3ff66f0a8ed250ed468e23cc9cb27.tar.bz2
upstream-afd7ec3b57c3ff66f0a8ed250ed468e23cc9cb27.zip
kirkwood: add support for two clones from Endian
They are Endian 4i Edge 200 and his clone Endian UTM Mini. Hardware: - SoC: Marvell 88F6281-A1 ARMv5TE Processor 1.2GHz - Ram: 512MB (4x Nanya NT5TU128M8GE-AC) - NAND Flash: 512MB (Micron 29F4G08AAC) - Lan 1-4: 4x GBE (Marvell 88E6171R-TFJ2) - Lan 5: 1x GBE (Marvell 88E1116R-NNC1) - Storage: MicroSD Slot - WLAN: MiniPCIe Slot present, and fitted with SparkLan WPEA-110N/E (Atheros AR9280 chipset) (ONLY Endian UTM Mini WLAN) - USB: 1x USB 2.0 port - Console: RJ-45 port - LEDs: 3x GPIO controlled Notes: - WLAN led (Endian UTM Mini) is drived by MPCIE card Installation by TFTP + serial: - Setup TFTP server and copy initramfs image - Connect serial console - Stop booting in u-boot - Do: setenv bootargs 'console=ttyS0,115200n8 earlyprintk' saveenv setenv serverip 192.168.1.1 setenv ipaddr 192.168.1.2 tftpboot 0x1200000 openwrt-kirkwood-endian_4i-edge-200-initramfs-uImage bootm 0x1200000 - copy sysupgrade image via ssh. - run sysupgrade Installation by USB + serial: - Copy initramfs image to fat32 usb drive - Connect pendrive to USB 2.0 front socket - Connect serial console - Stop booting in u-boot - Do: setenv bootargs 'console=ttyS0,115200n8 earlyprintk' saveenv usb reset fatload usb 0:1 0x1200000 openwrt-kirkwood-endian_4i-edge-200-initramfs-uImage bootm 0x1200000 - copy sysupgrade image via ssh. - run sysupgrade Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index eb3d684c80..4a2ca8d68e 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -140,6 +140,17 @@ define Device/ctera_c200-v1
endef
TARGET_DEVICES += ctera_c200-v1
+define Device/endian_4i-edge-200
+ DEVICE_VENDOR := Endian
+ DEVICE_MODEL := 4i Edge 200
+ DEVICE_ALT0_VENDOR := Endian
+ DEVICE_ALT0_MODEL := UTM Mini Firewall
+ DEVICE_PACKAGES := kmod-ath9k kmod-mvsdio wpad-basic-wolfssl
+ KERNEL_SIZE := 4096k
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += endian_4i-edge-200
+
define Device/globalscale_sheevaplug
DEVICE_VENDOR := Globalscale
DEVICE_MODEL := Sheevaplug