aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/image/apex
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /target/linux/ixp4xx-2.6/image/apex
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadupstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
upstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
upstream-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'target/linux/ixp4xx-2.6/image/apex')
-rw-r--r--target/linux/ixp4xx-2.6/image/apex/Makefile40
-rw-r--r--target/linux/ixp4xx-2.6/image/apex/patches/100-slugos-nslu2-armeb_config.patch20
2 files changed, 0 insertions, 60 deletions
diff --git a/target/linux/ixp4xx-2.6/image/apex/Makefile b/target/linux/ixp4xx-2.6/image/apex/Makefile
deleted file mode 100644
index 759a4ef75b..0000000000
--- a/target/linux/ixp4xx-2.6/image/apex/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=apex
-PKG_VERSION:=1.5.8
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.buici.com/pub/apex/ \
- ftp://metalab.unc.edu/pub/Linux/system/boot/apex/
-PKG_MD5SUM:=bb96cc8d50b4f00ee653f0800643ea8a
-
-include $(INCLUDE_DIR)/package.mk
-
-define Build/Configure
- $(MAKE) -C $(PKG_BUILD_DIR) \
- ARCH=arm \
- slugos-nslu2-armeb_config
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- ARCH=arm \
- all
-endef
-
-define Build/InstallDev
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/apex.bin $(TARGET)/apex-nslu2-armeb.bin
-endef
-
-$(eval $(call Build/DefaultTargets))
diff --git a/target/linux/ixp4xx-2.6/image/apex/patches/100-slugos-nslu2-armeb_config.patch b/target/linux/ixp4xx-2.6/image/apex/patches/100-slugos-nslu2-armeb_config.patch
deleted file mode 100644
index 34cb2a288a..0000000000
--- a/target/linux/ixp4xx-2.6/image/apex/patches/100-slugos-nslu2-armeb_config.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- apex-1.5.6/src/mach-ixp42x/slugos-nslu2-armeb_config 2007-06-02 10:06:45.000000000 +0930
-+++ apex-1.5.6/src/mach-ixp42x/slugos-nslu2-armeb_config~ 2007-06-03 02:22:18.000000000 +0930
-@@ -17,7 +17,7 @@
- #
- # General Setup
- #
--CONFIG_TARGET_DESCRIPTION="SlugOS NSLU2 (bigendian)"
-+CONFIG_TARGET_DESCRIPTION="OpenWRT NSLU2 (bigendian)"
- CONFIG_CROSS_COMPILE=""
- CONFIG_CC_OPTIMIZE_FOR_SIZE=y
- # CONFIG_CC_OPTIMIZE_FOR_SPEED is not set
-@@ -143,7 +143,7 @@
- # Overrides
- #
- CONFIG_ENV_DEFAULT_CMDLINE_OVERRIDE=y
--CONFIG_ENV_DEFAULT_CMDLINE="root=/dev/mtdblock4 rootfstype=jffs2 console=ttyS0,115200"
-+CONFIG_ENV_DEFAULT_CMDLINE="root=/dev/mtdblock4 rootfstype=squashfs,jffs2 console=ttyS0,115200 init=/etc/preinit noinitrd"
- # CONFIG_ENV_DEFAULT_STARTUP_OVERRIDE is not set
- CONFIG_USES_NOR_BOOTFLASH=y
- CONFIG_RELOCATE_SIMPLE=y