aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/image/apex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx-2.6/image/apex/Makefile')
-rw-r--r--target/linux/ixp4xx-2.6/image/apex/Makefile40
1 files changed, 0 insertions, 40 deletions
diff --git a/target/linux/ixp4xx-2.6/image/apex/Makefile b/target/linux/ixp4xx-2.6/image/apex/Makefile
deleted file mode 100644
index 759a4ef75b..0000000000
--- a/target/linux/ixp4xx-2.6/image/apex/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=apex
-PKG_VERSION:=1.5.8
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.buici.com/pub/apex/ \
- ftp://metalab.unc.edu/pub/Linux/system/boot/apex/
-PKG_MD5SUM:=bb96cc8d50b4f00ee653f0800643ea8a
-
-include $(INCLUDE_DIR)/package.mk
-
-define Build/Configure
- $(MAKE) -C $(PKG_BUILD_DIR) \
- ARCH=arm \
- slugos-nslu2-armeb_config
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- ARCH=arm \
- all
-endef
-
-define Build/InstallDev
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/apex.bin $(TARGET)/apex-nslu2-armeb.bin
-endef
-
-$(eval $(call Build/DefaultTargets))