aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2020-10-23 16:05:28 +0200
committerPaul Spooren <mail@aparcar.org>2021-04-29 10:55:07 +0200
commitd1f1e5269ed992e6fc30d575b43b0913c9e58ca2 (patch)
tree4836c37b12b7dc4d4575446d5e240ace98f0469f /target/linux/ipq40xx/image
parent43dad22025597cb535626757301e035187d02b25 (diff)
downloadupstream-d1f1e5269ed992e6fc30d575b43b0913c9e58ca2.tar.gz
upstream-d1f1e5269ed992e6fc30d575b43b0913c9e58ca2.tar.bz2
upstream-d1f1e5269ed992e6fc30d575b43b0913c9e58ca2.zip
ipq40xx: add support for MikroTik SXTsq 5 ac
This commit adds support for the MikroTik SXTsq 5 ac (RBSXTsqG-5acD), an outdoor 802.11ac wireless CPE with one 10/100/1000 Mbps Ethernet port. Specifications: - SoC: Qualcomm Atheros IPQ4018 - RAM: 256 MB - Storage: 16 MB NOR - Wireless: IPQ4018 (SoC) 802.11a/n/ac 2x2:2, 16 dBi antennae - Ethernet: IPQ4018 (SoC) 1x 10/100/1000 port, 10-28 Vdc PoE in - 1x Ethernet LED (green) - 7x user-controllable LEDs · 1x power (blue) · 1x user (green) · 5x rssi (green) Note: Serial UART is probably available on the board, but it has not been tested. Flashing: Boot via TFTP the initramfs image. Then, upload a sysupgrade image via SSH and flash it normally. More info at the "Common procedures for MikroTik products" page https://openwrt.org/toh/mikrotik/common. Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/mikrotik.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/mikrotik.mk b/target/linux/ipq40xx/image/mikrotik.mk
index 9509ef8577..7c2fa52738 100644
--- a/target/linux/ipq40xx/image/mikrotik.mk
+++ b/target/linux/ipq40xx/image/mikrotik.mk
@@ -18,3 +18,11 @@ define Device/mikrotik_hap-ac2
kmod-ath10k-ct-smallbuffers
endef
TARGET_DEVICES += mikrotik_hap-ac2
+
+define Device/mikrotik_sxtsq-5-ac
+ $(call Device/mikrotik_nor)
+ DEVICE_MODEL := SXTsq 5 ac (RBSXTsqG-5acD)
+ SOC := qcom-ipq4018
+ DEVICE_PACKAGES := ipq-wifi-mikrotik_sxtsq-5-ac rssileds
+endef
+TARGET_DEVICES += mikrotik_sxtsq-5-ac