aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorJan Alexander <jan@nalx.net>2021-01-09 11:33:34 +0100
committerDavid Bauer <mail@david-bauer.net>2021-01-14 01:04:02 +0100
commit6738b5e2ac80ec7bcaaa47edf20d9b479550ed8e (patch)
tree47033a54a1f78217eee3374320a1ca240e7b3ac5 /target/linux/ipq40xx/image
parent4e46beb31342a2b02e32185e91806093f68a77be (diff)
downloadupstream-6738b5e2ac80ec7bcaaa47edf20d9b479550ed8e.tar.gz
upstream-6738b5e2ac80ec7bcaaa47edf20d9b479550ed8e.tar.bz2
upstream-6738b5e2ac80ec7bcaaa47edf20d9b479550ed8e.zip
uboot-envtools: add support for Aruba AP-303 and AP-365
Both devices use u-boot env variables to boot OpenWrt from its flash partition. Using u-boot envtools, it is possible to change the bootcmd back to the stock firmware partition directly from OpenWrt without attaching a serial cable or even physically accessing the device. Signed-off-by: Jan Alexander <jan@nalx.net>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index c19dcb4039..f10ff002dc 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -156,6 +156,7 @@ endef
define Device/aruba_ap-303
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-303
+ DEVICE_PACKAGES += uboot-envtools
endef
TARGET_DEVICES += aruba_ap-303
@@ -168,7 +169,7 @@ TARGET_DEVICES += aruba_ap-303h
define Device/aruba_ap-365
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-365
- DEVICE_PACKAGES += kmod-hwmon-ad7418
+ DEVICE_PACKAGES += kmod-hwmon-ad7418 uboot-envtools
endef
TARGET_DEVICES += aruba_ap-365