aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx
diff options
context:
space:
mode:
authorJan Alexander <jan@nalx.net>2021-01-09 11:33:34 +0100
committerDavid Bauer <mail@david-bauer.net>2021-01-14 01:04:02 +0100
commit6738b5e2ac80ec7bcaaa47edf20d9b479550ed8e (patch)
tree47033a54a1f78217eee3374320a1ca240e7b3ac5 /target/linux/ipq40xx
parent4e46beb31342a2b02e32185e91806093f68a77be (diff)
downloadupstream-6738b5e2ac80ec7bcaaa47edf20d9b479550ed8e.tar.gz
upstream-6738b5e2ac80ec7bcaaa47edf20d9b479550ed8e.tar.bz2
upstream-6738b5e2ac80ec7bcaaa47edf20d9b479550ed8e.zip
uboot-envtools: add support for Aruba AP-303 and AP-365
Both devices use u-boot env variables to boot OpenWrt from its flash partition. Using u-boot envtools, it is possible to change the bootcmd back to the stock firmware partition directly from OpenWrt without attaching a serial cable or even physically accessing the device. Signed-off-by: Jan Alexander <jan@nalx.net>
Diffstat (limited to 'target/linux/ipq40xx')
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-303.dts2
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts1
-rw-r--r--target/linux/ipq40xx/image/Makefile3
3 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-303.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-303.dts
index a3cecddd6e..13f89d810c 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-303.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-303.dts
@@ -145,10 +145,8 @@
};
partition@380000 {
- /* This is empty */
label = "appsblenv";
reg = <0x380000 0x10000>;
- read-only;
};
partition@390000 {
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
index 1d4e50292e..988a4421b5 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
@@ -138,7 +138,6 @@
partition@e0000 {
label = "u-boot-env";
reg = <0xe0000 0x10000>;
- read-only;
};
partition@f0000 {
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index c19dcb4039..f10ff002dc 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -156,6 +156,7 @@ endef
define Device/aruba_ap-303
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-303
+ DEVICE_PACKAGES += uboot-envtools
endef
TARGET_DEVICES += aruba_ap-303
@@ -168,7 +169,7 @@ TARGET_DEVICES += aruba_ap-303h
define Device/aruba_ap-365
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-365
- DEVICE_PACKAGES += kmod-hwmon-ad7418
+ DEVICE_PACKAGES += kmod-hwmon-ad7418 uboot-envtools
endef
TARGET_DEVICES += aruba_ap-365