aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorDavide Fioravanti <pantanastyle@gmail.com>2020-09-02 02:10:16 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-11-01 00:56:51 +0100
commit2cb24b3f3cd89692f3c0bd137f3f560ada359bfa (patch)
tree05fcfc38ca7f046570d18f0d3b6674d450aad540 /target/linux/ipq40xx/image
parent6e137943442fb0ab66c34462fa19e5a4260eddd5 (diff)
downloadupstream-2cb24b3f3cd89692f3c0bd137f3f560ada359bfa.tar.gz
upstream-2cb24b3f3cd89692f3c0bd137f3f560ada359bfa.tar.bz2
upstream-2cb24b3f3cd89692f3c0bd137f3f560ada359bfa.zip
ipq40xx: add support for Netgear SRR60/SRS60 and RBR50/RBS50
The Netgear SRS60 and SRR60 (sold together as SRK60) are two almost identical AC3000 routers. The SRR60 has one port labeled as wan while the SRS60 not. The RBR50 and RBS50 (sold together as RBK50) have a different external shape but they have an USB 2.0 port on the back. This patch has been tested only on SRS60 and RBR50, but should work on SRR60 and RBS50. Hardware -------- SoC: Qualcomm IPQ4019 (717 MHz, 4 cores 4 threads) RAM: 512MB DDR3 FLASH: 4GB EMMC ETH: - 3x 10/100/1000 Mbps Ethernet - 1x 10/100/1000 Mbps Ethernet (WAN) WIFI: - 2.4GHz: 1x IPQ4019 (2x2:2) - 5GHz: 1x IPQ4019 (2x2:2) - 5GHz: 1x QCA9984 (4x4:4) - 6 internal antennas BTN: - 1x Reset button - 1x Sync button - 1x ON/OFF button LEDS: - 8 leds controlled by TLC59208F (they can be switched on/off independendently but the color can by changed by GPIOs) - 1x Red led (Power) - 1x Green led (Power) UART: - 115200-8-N-1 Everything works correctly. Installation ------------ These routers have a dual partition system. However this firmware works only on boot partition 1 and the OEM web interface will always flash on the partition currently not booted. The following steps will use the SRS60 firmware, but you have to chose the right firmware for your router. There are 2 ways to install Openwrt the first time: 1) Using NMRPflash 1. Download nmrpflash (https://github.com/jclehner/nmrpflash) 2. Put the openwrt-ipq40xx-generic-netgear_srs60-squashfs-factory.img file in the same folder of the nmrpflash executable 3. Connect your pc to the router using the port near the power button. 4. Run "nmrpflash -i XXX -f openwrt-ipq40xx-generic-netgear_srs60-squashfs-factory.img". Replace XXX with your network interface (can be identified by running "nmrpflash -L") 5. Power on the router and wait for the flash to complete. After about a minute the router should boot directly to Openwrt. If nothing happens try to reboot the router. If you have problems flashing try to set "10.164.183.253" as your computer IP address 2) Without NMRPflash The OEM web interface will always flash on the partition currently not booted, so to flash OpenWrt for the first time you have to switch to boot partition 2 and then flash the factory image directly from the OEM web interface. To switch on partition 2 you have to enable telnet first: 1. Go to http://192.168.1.250/debug.htm and check "Enable Telnet". 2. Connect through telent ("telnet 192.168.1.250") and login using admin/password. To read the current boot_part: artmtd -r boot_part To write the new boot_part: artmtd -w boot_part 02 Then reboot the router and then check again the current booted partition Now that you are on boot partition 2 you can flash the factory Openwrt image directly from the OEM web interface. Restore OEM Firmware -------------------- 1. Download the stock firmware from official netgear support. 2. Follow the nmrpflash procedure like above, using the official Netgear firmware (for example SRS60-V2.2.1.210.img) nmrpflash -i XXX -f SRS60-V2.2.1.210.img Notes ----- 1) You can check and edit the boot partition in the Uboot shell using the UART connection. "boot_partition_show" shows the current boot partition "boot_partition_set 1" sets the current boot partition to 1 2) Router mac addresses: LAN XX:XX:XX:XX:XX:69 WAN XX:XX:XX:XX:XX:6a WIFI 2G XX:XX:XX:XX:XX:69 WIFI 5G XX:XX:XX:XX:XX:6b WIFI 5G (2nd) XX:XX:XX:XX:XX:6c LABEL XX:XX:XX:XX:XX:69 Signed-off-by: Davide Fioravanti <pantanastyle@gmail.com> Signed-off-by: Robert Marko <robimarko@gmail.com> [added 5.10 changes for 901-arm-boot-add-dts-files.patch, moved sysupgrade mmc.sh to here and renamed it, various dtsi changes] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/generic.mk58
1 files changed, 58 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index e0cfa07541..dcfe3e027c 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -646,6 +646,64 @@ define Device/netgear_ex6150v2
endef
TARGET_DEVICES += netgear_ex6150v2
+define Device/netgear_orbi
+ $(call Device/DniImage)
+ SOC := qcom-ipq4019
+ DEVICE_VENDOR := NETGEAR
+ IMAGE/factory.img := append-kernel | pad-offset 128k 64 | \
+ append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | \
+ append-rootfs | pad-rootfs | netgear-dni
+ IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | \
+ sysupgrade-tar rootfs=$$$$@ | append-metadata
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct e2fsprogs kmod-fs-ext4 losetup
+endef
+
+define Device/netgear_rbx50
+ $(call Device/netgear_orbi)
+ NETGEAR_HW_ID := 29765352+0+4000+512+2x2+2x2+4x4
+ KERNEL_SIZE := 3932160
+ ROOTFS_SIZE := 32243712
+ IMAGE_SIZE := 36175872
+endef
+
+define Device/netgear_rbr50
+ $(call Device/netgear_rbx50)
+ DEVICE_MODEL := RBR50
+ DEVICE_VARIANT := v1
+ NETGEAR_BOARD_ID := RBR50
+endef
+TARGET_DEVICES += netgear_rbr50
+
+define Device/netgear_rbs50
+ $(call Device/netgear_rbx50)
+ DEVICE_MODEL := RBS50
+ DEVICE_VARIANT := v1
+ NETGEAR_BOARD_ID := RBS50
+endef
+TARGET_DEVICES += netgear_rbs50
+
+define Device/netgear_srx60
+ $(call Device/netgear_orbi)
+ NETGEAR_HW_ID := 29765352+0+4096+512+2x2+2x2+4x4
+ KERNEL_SIZE := 3932160
+ ROOTFS_SIZE := 32243712
+ IMAGE_SIZE := 36175872
+endef
+
+define Device/netgear_srr60
+ $(call Device/netgear_srx60)
+ DEVICE_MODEL := SRR60
+ NETGEAR_BOARD_ID := SRR60
+endef
+TARGET_DEVICES += netgear_srr60
+
+define Device/netgear_srs60
+ $(call Device/netgear_srx60)
+ DEVICE_MODEL := SRS60
+ NETGEAR_BOARD_ID := SRS60
+endef
+TARGET_DEVICES += netgear_srs60
+
define Device/netgear_wac510
$(call Device/FitImage)
$(call Device/UbiFit)