aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/iop32x/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-03 13:54:25 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-03 13:54:25 +0000
commitddc83122673b8bcc7cb3a2217ccc5964977ed5ce (patch)
treed5c34c380227d7a85932f3aa6528fad1445c9b1c /target/linux/iop32x/Makefile
parent825915f38ff84f8f9c64ffc6db491a281cfbce91 (diff)
downloadupstream-ddc83122673b8bcc7cb3a2217ccc5964977ed5ce.tar.gz
upstream-ddc83122673b8bcc7cb3a2217ccc5964977ed5ce.tar.bz2
upstream-ddc83122673b8bcc7cb3a2217ccc5964977ed5ce.zip
fix EABI kernel config on IOP32x
SVN-Revision: 10720
Diffstat (limited to 'target/linux/iop32x/Makefile')
-rw-r--r--target/linux/iop32x/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/iop32x/Makefile b/target/linux/iop32x/Makefile
index ccecf204c8..82a3367a6a 100644
--- a/target/linux/iop32x/Makefile
+++ b/target/linux/iop32x/Makefile
@@ -15,4 +15,10 @@ LINUX_VERSION:=2.6.24.2
include $(INCLUDE_DIR)/target.mk
+define Kernel/Configure
+ $(call Kernel/Configure/Default)
+ $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+ $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
$(eval $(call BuildTarget))