aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/iop32x/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/iop32x/Makefile b/target/linux/iop32x/Makefile
index ccecf204c8..82a3367a6a 100644
--- a/target/linux/iop32x/Makefile
+++ b/target/linux/iop32x/Makefile
@@ -15,4 +15,10 @@ LINUX_VERSION:=2.6.24.2
include $(INCLUDE_DIR)/target.mk
+define Kernel/Configure
+ $(call Kernel/Configure/Default)
+ $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+ $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
$(eval $(call BuildTarget))