aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-21 17:56:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-21 17:56:18 +0000
commit2e62ff9320035e47a945cac48b16a4428844e5d7 (patch)
treeac76dc579b8e4de976d8d2b7bcce038619ff4e57 /target/linux/generic/patches-3.10
parent2f2ed5c5c161d77ae94f70c07caaeb1edbb419df (diff)
downloadupstream-2e62ff9320035e47a945cac48b16a4428844e5d7.tar.gz
upstream-2e62ff9320035e47a945cac48b16a4428844e5d7.tar.bz2
upstream-2e62ff9320035e47a945cac48b16a4428844e5d7.zip
kernel/3.10: add partition parser for Seama firmwares
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38114
Diffstat (limited to 'target/linux/generic/patches-3.10')
-rw-r--r--target/linux/generic/patches-3.10/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch b/target/linux/generic/patches-3.10/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch
new file mode 100644
index 0000000000..016a9b6e4c
--- /dev/null
+++ b/target/linux/generic/patches-3.10/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -50,6 +50,10 @@ config MTD_SPLIT_SQUASHFS_ROOT
+
+ comment "Firmware partition parsers"
+
++config MTD_SPLIT_SEAMA_FW
++ bool "Seama firmware parser"
++ select MTD_SPLIT
++
+ config MTD_SPLIT_UIMAGE_FW
+ bool "uImage based firmware partition parser"
+ select MTD_SPLIT
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD) += mtd.o
+ mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
+
+ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
++mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
+ mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
+ mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
+