aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-21 17:56:09 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-21 17:56:09 +0000
commit2f2ed5c5c161d77ae94f70c07caaeb1edbb419df (patch)
treee330e68c3d05fb0068a44fc662264ed80a30861f /target/linux/generic/patches-3.10
parent98db90576c2f54a69f8099eb427e1abfcfbe2800 (diff)
downloadupstream-2f2ed5c5c161d77ae94f70c07caaeb1edbb419df.tar.gz
upstream-2f2ed5c5c161d77ae94f70c07caaeb1edbb419df.tar.bz2
upstream-2f2ed5c5c161d77ae94f70c07caaeb1edbb419df.zip
kernel/3.10: add partition parser for uImage firmwares
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38113
Diffstat (limited to 'target/linux/generic/patches-3.10')
-rw-r--r--target/linux/generic/patches-3.10/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch b/target/linux/generic/patches-3.10/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
new file mode 100644
index 0000000000..02697f64eb
--- /dev/null
+++ b/target/linux/generic/patches-3.10/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -48,6 +48,12 @@ config MTD_SPLIT_SQUASHFS_ROOT
+ offset and size of the unused portion of a rootfs partition
+ containing a squashfs.
+
++comment "Firmware partition parsers"
++
++config MTD_SPLIT_UIMAGE_FW
++ bool "uImage based firmware partition parser"
++ select MTD_SPLIT
++
+ config MTD_SPLIT
+ def_bool n
+ help
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdconc
+
+ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
+ mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
++mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
+
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o