aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-19 18:17:29 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-21 20:49:18 +0100
commit80a3ecc894897f7fa42ab0b98c61ae7533ea7703 (patch)
tree66061fa9b7417e118124a5990466a77e772d9575 /target/linux/bmips
parent61f3c3b1eebd598b62f03cb2c63dde965624e0f1 (diff)
downloadupstream-80a3ecc894897f7fa42ab0b98c61ae7533ea7703.tar.gz
upstream-80a3ecc894897f7fa42ab0b98c61ae7533ea7703.tar.bz2
upstream-80a3ecc894897f7fa42ab0b98c61ae7533ea7703.zip
bmips: add Huawei HG253s v2 support
Huawei HG253s v2 is a BCM6362 with 128M RAM, internal wifi and external BCM53124S switch. This device is already supported in bcm63xx target, so more information can be found in https://openwrt.org/toh/huawei/hg253s_v2. It's a perfect example of a device with internal and external switch coexistance since most devices only have ports on one of the switches but not both of them. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips')
-rw-r--r--target/linux/bmips/dts/bcm6362-huawei-hg253s-v2.dts241
-rw-r--r--target/linux/bmips/image/bcm63xx_nand.mk21
-rw-r--r--target/linux/bmips/nand/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/bmips/nand/base-files/lib/upgrade/platform.sh1
4 files changed, 264 insertions, 0 deletions
diff --git a/target/linux/bmips/dts/bcm6362-huawei-hg253s-v2.dts b/target/linux/bmips/dts/bcm6362-huawei-hg253s-v2.dts
new file mode 100644
index 0000000000..c3bf11629b
--- /dev/null
+++ b/target/linux/bmips/dts/bcm6362-huawei-hg253s-v2.dts
@@ -0,0 +1,241 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+
+#include "bcm6362.dtsi"
+
+/ {
+ model = "Huawei HG253s v2";
+ compatible = "huawei,hg253s-v2", "brcm,bcm6362";
+
+ aliases {
+ led-boot = &led_phone_green;
+ led-failsafe = &led_phone_green;
+ led-upgrade = &led_phone_green;
+
+ led-internet = &led_internet_green;
+ led-usb = &led_usb_green;
+ led-wireless = &led_wireless_green;
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ debounce-interval = <60>;
+ };
+
+ wlan {
+ label = "wlan";
+ gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WLAN>;
+ debounce-interval = <60>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 26 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_phone_green: led@28 {
+ label = "green:phone";
+ gpios = <&gpio 28 GPIO_ACTIVE_LOW>;
+ };
+
+ led_usb_green: led@30 {
+ label = "green:usb";
+ gpios = <&gpio 30 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ethernet {
+ status = "okay";
+
+ nvmem-cells = <&macaddr_cferom_6a0>;
+ nvmem-cell-names = "mac-address";
+};
+
+&leds {
+ status = "okay";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_leds>;
+
+ led_internet_green: led@3 {
+ reg = <3>;
+ active-low;
+ label = "green:internet";
+ };
+
+ led_wireless_green: led@5 {
+ reg = <5>;
+ active-low;
+ label = "green:wifi";
+ };
+};
+
+&lsspi {
+ status = "okay";
+
+ switch@0 {
+ compatible = "brcm,bcm53125";
+ reg = <0>;
+ spi-max-frequency = <781000>;
+
+ dsa,member = <1 0>;
+
+ ports {
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ port@1 {
+ reg = <1>;
+ label = "lan4";
+ };
+
+ port@2 {
+ reg = <2>;
+ label = "lan3";
+ };
+
+ port@3 {
+ reg = <3>;
+ label = "lan2";
+ };
+
+ port@4 {
+ reg = <4>;
+ label = "lan1";
+ };
+
+ port@8 {
+ reg = <8>;
+ label = "cpu";
+
+ phy-mode = "rgmii";
+ ethernet = <&switch0port4>;
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ asym-pause;
+ pause;
+ };
+ };
+ };
+ };
+};
+
+&mdio_ext {
+ phy24: ethernet-phy@18 {
+ compatible = "ethernet-phy-ieee802.3-c22";
+ reg = <24>;
+ };
+};
+
+&nflash {
+ status = "okay";
+
+ nandcs@0 {
+ compatible = "brcm,nandcs";
+ reg = <0>;
+ nand-ecc-step-size = <512>;
+ nand-ecc-strength = <15>;
+ nand-on-flash-bbt;
+ brcm,nand-oob-sector-size = <64>;
+
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ cferom: partition@0 {
+ label = "cferom";
+ reg = <0x0000000 0x0020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "brcm,wfi";
+ label = "wfi";
+ reg = <0x0020000 0x7d80000>;
+ };
+
+ partition@7da0000 {
+ label = "nvram";
+ reg = <0x7da0000 0x160000>;
+ };
+ };
+ };
+};
+
+&ohci {
+ status = "okay";
+};
+
+&pinctrl {
+ pinctrl_leds: leds {
+ function = "led";
+ pins = "gpio3", "gpio5";
+ };
+};
+
+&switch0 {
+ dsa,member = <0 0>;
+
+ ports {
+ switch0port4: port@4 {
+ reg = <4>;
+ label = "extsw";
+
+ phy-mode = "rgmii";
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ };
+ };
+
+ port@5 {
+ reg = <5>;
+ label = "wan";
+
+ phy-handle = <&phy24>;
+ phy-mode = "rgmii-txid";
+ };
+ };
+};
+
+&uart0 {
+ status = "okay";
+};
+
+&usbh {
+ status = "okay";
+};
+
+&cferom {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_cferom_6a0: macaddr@6a0 {
+ reg = <0x6a0 0x6>;
+ };
+};
diff --git a/target/linux/bmips/image/bcm63xx_nand.mk b/target/linux/bmips/image/bcm63xx_nand.mk
index 82b04891d5..6c4655bbab 100644
--- a/target/linux/bmips/image/bcm63xx_nand.mk
+++ b/target/linux/bmips/image/bcm63xx_nand.mk
@@ -63,6 +63,27 @@ define Device/comtrend_vr-3032u
endef
TARGET_DEVICES += comtrend_vr-3032u
+define Device/huawei_hg253s-v2
+ $(Device/bcm63xx-nand)
+ IMAGES := flash.bin sysupgrade.bin
+ IMAGE/flash.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | cfe-jffs2-cferam | append-ubi
+ DEVICE_VENDOR := Huawei
+ DEVICE_MODEL := HG253s
+ DEVICE_VARIANT := v2
+ CHIP_ID := 6362
+ CFE_PART_FLAGS := 1
+ CFE_PART_ID := 0x0001EFEE
+ CFE_RAM_FILE := huawei,hg253s-v2/cferam.000
+ CFE_RAM_JFFS2_NAME := cferam.000
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES)
+ CFE_WFI_FLASH_TYPE := 3
+endef
+TARGET_DEVICES += huawei_hg253s-v2
+
define Device/netgear_dgnd3700-v2
$(Device/bcm63xx-nand)
DEVICE_VENDOR := NETGEAR
diff --git a/target/linux/bmips/nand/base-files/etc/board.d/02_network b/target/linux/bmips/nand/base-files/etc/board.d/02_network
index 3134116bc2..ce4440270c 100644
--- a/target/linux/bmips/nand/base-files/etc/board.d/02_network
+++ b/target/linux/bmips/nand/base-files/etc/board.d/02_network
@@ -9,6 +9,7 @@ comtrend,vr-3032u)
ucidef_set_bridge_device switch
ucidef_set_interface_lan "lan1 lan2 lan3 lan4"
;;
+huawei,hg253s-v2 |\
netgear,dgnd3700-v2)
ucidef_set_bridge_device switch
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan"
diff --git a/target/linux/bmips/nand/base-files/lib/upgrade/platform.sh b/target/linux/bmips/nand/base-files/lib/upgrade/platform.sh
index 05e6db1836..33217ed975 100644
--- a/target/linux/bmips/nand/base-files/lib/upgrade/platform.sh
+++ b/target/linux/bmips/nand/base-files/lib/upgrade/platform.sh
@@ -46,6 +46,7 @@ cfe_jffs2_nand_upgrade() {
platform_do_upgrade() {
case "$(board_name)" in
comtrend,vr-3032u|\
+ huawei,hg253s-v2|\
netgear,dgnd3700-v2)
cfe_jffs2_nand_upgrade "$1"
;;