aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm63xx_nand.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bmips/image/bcm63xx_nand.mk')
-rw-r--r--target/linux/bmips/image/bcm63xx_nand.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm63xx_nand.mk b/target/linux/bmips/image/bcm63xx_nand.mk
index 82b04891d5..6c4655bbab 100644
--- a/target/linux/bmips/image/bcm63xx_nand.mk
+++ b/target/linux/bmips/image/bcm63xx_nand.mk
@@ -63,6 +63,27 @@ define Device/comtrend_vr-3032u
endef
TARGET_DEVICES += comtrend_vr-3032u
+define Device/huawei_hg253s-v2
+ $(Device/bcm63xx-nand)
+ IMAGES := flash.bin sysupgrade.bin
+ IMAGE/flash.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | cfe-jffs2-cferam | append-ubi
+ DEVICE_VENDOR := Huawei
+ DEVICE_MODEL := HG253s
+ DEVICE_VARIANT := v2
+ CHIP_ID := 6362
+ CFE_PART_FLAGS := 1
+ CFE_PART_ID := 0x0001EFEE
+ CFE_RAM_FILE := huawei,hg253s-v2/cferam.000
+ CFE_RAM_JFFS2_NAME := cferam.000
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES)
+ CFE_WFI_FLASH_TYPE := 3
+endef
+TARGET_DEVICES += huawei_hg253s-v2
+
define Device/netgear_dgnd3700-v2
$(Device/bcm63xx-nand)
DEVICE_VENDOR := NETGEAR