aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-18 18:30:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-18 18:30:29 +0000
commitdc6794b88c4512caa66c47574ca7994cd029c3fc (patch)
tree4de5acb0773942b358c3a896608683dbaab655e3 /target/linux/au1000-2.6/image/Makefile
parent2f50e4ee3fd466a75a7cedd55193027f13c4d445 (diff)
downloadupstream-dc6794b88c4512caa66c47574ca7994cd029c3fc.tar.gz
upstream-dc6794b88c4512caa66c47574ca7994cd029c3fc.tar.bz2
upstream-dc6794b88c4512caa66c47574ca7994cd029c3fc.zip
some platform support path name cleanup
SVN-Revision: 5846
Diffstat (limited to 'target/linux/au1000-2.6/image/Makefile')
-rw-r--r--target/linux/au1000-2.6/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/au1000-2.6/image/Makefile b/target/linux/au1000-2.6/image/Makefile
index c9ab7caca9..b5ba3d4542 100644
--- a/target/linux/au1000-2.6/image/Makefile
+++ b/target/linux/au1000-2.6/image/Makefile
@@ -21,7 +21,7 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE)
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
DROP_SECTIONS := .reginfo .mdebug .comment .note .pdr .options .MIPS.options
@@ -32,13 +32,13 @@ define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
# Build RAM image
- $(MAKE) -C ../../generic-2.6/image/lzma-loader \
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
$(LOADER_MAKEOPTS) \
clean compile
$(OBJCOPY_SREC) $(KDIR)/loader.elf $(KDIR)/kernel.ram.srec
# Build Flash image
- $(MAKE) -C ../../generic-2.6/image/lzma-loader \
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
$(LOADER_MAKEOPTS) \
IMAGE_COPY=1 \
LOADER_ENTRY=$(FLASH_KERNEL) \