aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-18 18:30:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-18 18:30:29 +0000
commitdc6794b88c4512caa66c47574ca7994cd029c3fc (patch)
tree4de5acb0773942b358c3a896608683dbaab655e3 /target/linux
parent2f50e4ee3fd466a75a7cedd55193027f13c4d445 (diff)
downloadupstream-dc6794b88c4512caa66c47574ca7994cd029c3fc.tar.gz
upstream-dc6794b88c4512caa66c47574ca7994cd029c3fc.tar.bz2
upstream-dc6794b88c4512caa66c47574ca7994cd029c3fc.zip
some platform support path name cleanup
SVN-Revision: 5846
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/aruba-2.6/image/Makefile4
-rw-r--r--target/linux/au1000-2.6/image/Makefile6
-rw-r--r--target/linux/brcm63xx-2.6/image/Makefile4
-rw-r--r--target/linux/rb532-2.6/image/Makefile4
4 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/aruba-2.6/image/Makefile b/target/linux/aruba-2.6/image/Makefile
index 37dd6fccb0..e486b30ef2 100644
--- a/target/linux/aruba-2.6/image/Makefile
+++ b/target/linux/aruba-2.6/image/Makefile
@@ -18,12 +18,12 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE)
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
endef
define Image/BuildKernel
diff --git a/target/linux/au1000-2.6/image/Makefile b/target/linux/au1000-2.6/image/Makefile
index c9ab7caca9..b5ba3d4542 100644
--- a/target/linux/au1000-2.6/image/Makefile
+++ b/target/linux/au1000-2.6/image/Makefile
@@ -21,7 +21,7 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE)
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
DROP_SECTIONS := .reginfo .mdebug .comment .note .pdr .options .MIPS.options
@@ -32,13 +32,13 @@ define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
# Build RAM image
- $(MAKE) -C ../../generic-2.6/image/lzma-loader \
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
$(LOADER_MAKEOPTS) \
clean compile
$(OBJCOPY_SREC) $(KDIR)/loader.elf $(KDIR)/kernel.ram.srec
# Build Flash image
- $(MAKE) -C ../../generic-2.6/image/lzma-loader \
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
$(LOADER_MAKEOPTS) \
IMAGE_COPY=1 \
LOADER_ENTRY=$(FLASH_KERNEL) \
diff --git a/target/linux/brcm63xx-2.6/image/Makefile b/target/linux/brcm63xx-2.6/image/Makefile
index 27c7b49c39..5c16f0541c 100644
--- a/target/linux/brcm63xx-2.6/image/Makefile
+++ b/target/linux/brcm63xx-2.6/image/Makefile
@@ -18,12 +18,12 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE)
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) compile
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) compile
endef
define Image/Build
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 1f3a88ba40..4e1c1addd1 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -25,7 +25,7 @@ define Build/Compile
endef
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
define Image/Prepare
@@ -35,7 +35,7 @@ endef
define Image/BuildKernel
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
$(CP) $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
endef