aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorSven Eckelmann <sven@narfation.org>2020-11-23 13:41:34 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-19 15:39:36 +0100
commitd9a3af46d8a1001223c2a327f449b7048d0fd5f6 (patch)
tree85f21ca165b82fb16e0967bede79f9a8e5ba7d2a /target/linux/ath79
parent4b35999588ee6dbe1fd818760b358b1191ddd0be (diff)
downloadupstream-d9a3af46d8a1001223c2a327f449b7048d0fd5f6.tar.gz
upstream-d9a3af46d8a1001223c2a327f449b7048d0fd5f6.tar.bz2
upstream-d9a3af46d8a1001223c2a327f449b7048d0fd5f6.zip
ath79: Add support for OpenMesh MR600 v2
Device specifications: ====================== * Qualcomm/Atheros AR9344 rev 2 * 560/450/225 MHz (CPU/DDR/AHB) * 128 MB of RAM * 16 MB of SPI NOR flash - 2x 7 MB available; but one of the 7 MB regions is the recovery image * 2T2R 2.4 GHz Wi-Fi * 2T2R 5 GHz Wi-Fi * 8x GPIO-LEDs (6x wifi, 1x wps, 1x power) * 1x GPIO-button (reset) * external h/w watchdog (enabled by default)) * TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX) * 1x ethernet - AR8035 ethernet PHY (RGMII) - 10/100/1000 Mbps Ethernet - 802.3af POE - used as LAN interface * 12-24V 1A DC * internal antennas Flashing instructions: ====================== Various methods can be used to install the actual image on the flash. Two easy ones are: ap51-flash ---------- The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be used to transfer the image to the u-boot when the device boots up. initramfs from TFTP ------------------- The serial console must be used to access the u-boot shell during bootup. It can then be used to first boot up the initramfs image from a TFTP server (here with the IP 192.168.1.21): setenv serverip 192.168.1.21 setenv ipaddr 192.168.1.1 tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr The actual sysupgrade image can then be transferred (on the LAN port) to the device via scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/ On the device, the sysupgrade must then be started using sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin Signed-off-by: Sven Eckelmann <sven@narfation.org> [rebase, add LED migration] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/dts/ar9344_openmesh_mr600-v2.dts71
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom3
-rw-r--r--target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration3
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ath79/image/generic.mk7
6 files changed, 85 insertions, 1 deletions
diff --git a/target/linux/ath79/dts/ar9344_openmesh_mr600-v2.dts b/target/linux/ath79/dts/ar9344_openmesh_mr600-v2.dts
new file mode 100644
index 0000000000..988066798f
--- /dev/null
+++ b/target/linux/ath79/dts/ar9344_openmesh_mr600-v2.dts
@@ -0,0 +1,71 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9344_openmesh_mr600.dtsi"
+
+/ {
+ compatible = "openmesh,mr600-v2", "qca,ar9344";
+ model = "OpenMesh MR600 v2";
+
+ aliases {
+ led-boot = &led_power_blue;
+ led-failsafe = &led_power_blue;
+ led-running = &led_power_blue;
+ led-upgrade = &led_power_blue;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ wifi5g_red {
+ label = "red:wifi5g";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ };
+
+ wps_blue {
+ label = "blue:wps";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ };
+
+ led_power_blue: power_blue {
+ label = "blue:power";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wifi2g_green {
+ label = "green:wifi2g";
+ gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ wifi2g_yellow {
+ label = "yellow:wifi2g";
+ gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi2g_red {
+ label = "red:wifi2g";
+ gpios = <&gpio 20 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi5g_green {
+ label = "green:wifi5g";
+ gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wifi5g_yellow {
+ label = "yellow:wifi5g";
+ gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ watchdog {
+ compatible = "linux,wdt-gpio";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ hw_algo = "toggle";
+ /* hw_margin_ms is actually 300s but driver limits it to 60s */
+ hw_margin_ms = <60000>;
+ always-running;
+ };
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index df0842fc63..3c37781c0e 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -47,6 +47,7 @@ ath79_setup_interfaces()
ocedo,koala|\
ocedo,raccoon|\
openmesh,mr600-v1|\
+ openmesh,mr600-v2|\
pcs,cap324|\
pisen,ts-d084|\
pisen,wmb001n|\
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index 150c70d68b..d50d8d9f82 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -120,7 +120,8 @@ case "$FIRMWARE" in
ubnt,rocket-m)
caldata_extract "art" 0x1000 0x1000
;;
- openmesh,mr600-v1)
+ openmesh,mr600-v1|\
+ openmesh,mr600-v2)
caldata_extract "ART" 0x5000 0x440
;;
wd,mynet-n750)
diff --git a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
index 871d84ed63..88c4f527b7 100644
--- a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
+++ b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
@@ -20,6 +20,9 @@ glinet,gl-mifi)
openmesh,mr600-v1)
migrate_leds ":wlan58=:wifi5g"
;;
+openmesh,mr600-v2)
+ migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
+ ;;
pcs,cap324)
migrate_leds "lan:amber=amber:lan" "lan:green=green:lan"
;;
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index 81dd911564..e14adb38fa 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -51,6 +51,7 @@ platform_do_upgrade() {
redboot_fis_do_upgrade "$1" linux
;;
openmesh,mr600-v1|\
+ openmesh,mr600-v2|\
openmesh,om2p-v2|\
openmesh,om2p-v4|\
openmesh,om2p-hs-v1|\
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 14546f6ade..9a182cab79 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1545,6 +1545,13 @@ define Device/openmesh_mr600-v1
endef
TARGET_DEVICES += openmesh_mr600-v1
+define Device/openmesh_mr600-v2
+ $(Device/openmesh_mr600-common)
+ DEVICE_VARIANT := v2
+ SUPPORTED_DEVICES += mr600v2
+endef
+TARGET_DEVICES += openmesh_mr600-v2
+
define Device/openmesh_om2p-common
DEVICE_VENDOR := OpenMesh
DEVICE_PACKAGES := uboot-envtools