aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2021-04-25 22:41:46 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-06-07 00:23:51 +0200
commit3e0387b3db86b35e101b147692d0af04c5083ca9 (patch)
tree598c9c1a7e9a92d07542f2310f1579cf2095f952 /target/linux/ath79/image
parenta4e2766a5bfa1ac1c706d1cd58c6706ffdcde895 (diff)
downloadupstream-3e0387b3db86b35e101b147692d0af04c5083ca9.tar.gz
upstream-3e0387b3db86b35e101b147692d0af04c5083ca9.tar.bz2
upstream-3e0387b3db86b35e101b147692d0af04c5083ca9.zip
ath79: Support for Ubiquiti Rocket 5AC Lite
The Ubiquiti Rocket 5AC Lite (R5AC-Lite) is an outdoor router. Specifications: - SoC: Qualcomm Atheros QCA9558 - RAM: 128 MB - Flash: 16 MB SPI - Ethernet: 1x 10/100/1000 Mbps - WiFi 5 GHz: QCA988x - Buttons: 1x (reset) - LEDs: 1x power, 1x Ethernet, 4x RSSI Installation: - Instructions for XC-type Ubiquiti: https://openwrt.org/toh/ubiquiti/common Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 733d803d7a..f8e1d1e432 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -337,6 +337,15 @@ define Device/ubnt_powerbridge-m
endef
TARGET_DEVICES += ubnt_powerbridge-m
+define Device/ubnt_rocket-5ac-lite
+ $(Device/ubnt-xc)
+ SOC := qca9558
+ DEVICE_MODEL := Rocket 5AC
+ DEVICE_VARIANT := Lite
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += ubnt_rocket-5ac-lite
+
define Device/ubnt_rocket-m
$(Device/ubnt-xm)
SOC := ar7241