aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorLeon M. George <leon@georgemail.eu>2019-07-26 20:34:01 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-26 02:14:45 +0200
commit15f585afc5b66f5addb6667001c303b5fd502ce5 (patch)
tree266ba2744345036537ac88f09667ab06963db46c /target/linux/ath79/image
parentf8ea7c53fd227a9c21f0ca45a2c3345312ea54b5 (diff)
downloadupstream-15f585afc5b66f5addb6667001c303b5fd502ce5.tar.gz
upstream-15f585afc5b66f5addb6667001c303b5fd502ce5.tar.bz2
upstream-15f585afc5b66f5addb6667001c303b5fd502ce5.zip
ath79: add support for Compex WPJ563
Specifications: SoC: QCA9563 DRAM: 128MB DDR2 Flash: 16MB SPI-NOR 2 Gigabit ethernet ports 3×3 2.4GHz on-board radio miniPCIe slot that supports 5GHz radio PoE 24V passive or 36V-56V passive with optional IEEE 802.3af/at USB 3.0 header Installation: To install, either start tftp in bin/targets/ath79/generic/ and use the u-boot prompt over UART: tftpboot 0x80500000 openwrt-ath79-generic-compex_wpj563-squashfs-sysupgrade.bin erase 0x9f680000 +1 erase 0x9f030000 +$filesize cp.b $fileaddr 0x9f030000 $filesize boot The cpximg file can be used with sysupgrade in the stock firmware (add SSH key in luci for root access) or with the built-in cpximg loader. The cpximg loader can be started either by holding the reset button during power up or by entering the u-boot prompt and entering 'cpximg'. Once it's running, a TFTP-server under 192.168.1.1 will accept the image appropriate for the board revision that is etched on the board. For example, if the board is labelled '7A02': tftp -v -m binary 192.168.1.1 -c put openwrt-ath79-generic-compex_wpj563-squashfs-cpximg-7a02.bin MAC addresses: <&uboot 0x2e010> *:71 (label) <&uboot 0x2e018> *:72 <&uboot 0x2e020> *:73 <&uboot 0x2e028> *:74 Only the first two are used (for ethernet), the WiFi modules have separate (valid) addresses. The latter two addresses are not used. Signed-off-by: Leon M. George <leon@georgemail.eu>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 8dc16983e1..adc7772c0e 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -502,6 +502,18 @@ define Device/compex_wpj531-16m
endef
TARGET_DEVICES += compex_wpj531-16m
+define Device/compex_wpj563
+ SOC := qca9563
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb3
+ IMAGE_SIZE := 16128k
+ DEVICE_VENDOR := Compex
+ DEVICE_MODEL := WPJ563
+ SUPPORTED_DEVICES += wpj563
+ IMAGES += cpximg-7a02.bin
+ IMAGE/cpximg-7a02.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | mkmylofw_16m 0x694 2
+endef
+TARGET_DEVICES += compex_wpj563
+
define Device/devolo_dvl1200e
SOC := qca9558
DEVICE_VENDOR := devolo