aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 8dc16983e1..adc7772c0e 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -502,6 +502,18 @@ define Device/compex_wpj531-16m
endef
TARGET_DEVICES += compex_wpj531-16m
+define Device/compex_wpj563
+ SOC := qca9563
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb3
+ IMAGE_SIZE := 16128k
+ DEVICE_VENDOR := Compex
+ DEVICE_MODEL := WPJ563
+ SUPPORTED_DEVICES += wpj563
+ IMAGES += cpximg-7a02.bin
+ IMAGE/cpximg-7a02.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | mkmylofw_16m 0x694 2
+endef
+TARGET_DEVICES += compex_wpj563
+
define Device/devolo_dvl1200e
SOC := qca9558
DEVICE_VENDOR := devolo