aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-10-07 15:13:31 +0200
committerMathias Kresin <dev@kresin.me>2018-10-07 15:49:25 +0200
commit5815bb2e41389f484516cf62008c42a4e9ff8327 (patch)
tree090822e7998f94c5f73d74d536e0f4e949a4f524 /target/linux/ath79/image/tiny-tp-link.mk
parent6d1abbcab482556ad13cc7285680b97d4a28a465 (diff)
downloadupstream-5815bb2e41389f484516cf62008c42a4e9ff8327.tar.gz
upstream-5815bb2e41389f484516cf62008c42a4e9ff8327.tar.bz2
upstream-5815bb2e41389f484516cf62008c42a4e9ff8327.zip
ath79: add support for TP-Link TL-WA901ND v2
This commit adds support for the TP-Link TL-WR901ND v2 access point. CPU: Atheros AR9132 400MHz RAM: 32MB FLASH: 4MiB WiFi: Atheros AR9103 3x3:2 bgn LED: Power (static on) LAN (controlled by PHY) SYS, WiFi, QSS toggleable BTN: Reset, QSS Installation: Upload the factory image via the vendor-GUI. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index dadcd24b42..e0c7e283c8 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -51,6 +51,14 @@ define Device/tplink_tl-mr3420-v1
endef
TARGET_DEVICES += tplink_tl-mr3420-v1
+define Device/tplink_tl-wa901nd-v2
+ $(Device/tplink-4m)
+ ATH_SOC := ar9132
+ DEVICE_TITLE := TP-Link TL-WA901ND v2
+ TPLINK_HWID := 0x09010002
+endef
+TARGET_DEVICES += tplink_tl-wa901nd-v2
+
define Device/tplink_tl-wr703n
$(Device/tplink-4mlzma)
ATH_SOC := ar9331