aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-10-07 15:13:31 +0200
committerMathias Kresin <dev@kresin.me>2018-10-07 15:49:25 +0200
commit5815bb2e41389f484516cf62008c42a4e9ff8327 (patch)
tree090822e7998f94c5f73d74d536e0f4e949a4f524 /target
parent6d1abbcab482556ad13cc7285680b97d4a28a465 (diff)
downloadupstream-5815bb2e41389f484516cf62008c42a4e9ff8327.tar.gz
upstream-5815bb2e41389f484516cf62008c42a4e9ff8327.tar.bz2
upstream-5815bb2e41389f484516cf62008c42a4e9ff8327.zip
ath79: add support for TP-Link TL-WA901ND v2
This commit adds support for the TP-Link TL-WR901ND v2 access point. CPU: Atheros AR9132 400MHz RAM: 32MB FLASH: 4MiB WiFi: Atheros AR9103 3x3:2 bgn LED: Power (static on) LAN (controlled by PHY) SYS, WiFi, QSS toggleable BTN: Reset, QSS Installation: Upload the factory image via the vendor-GUI. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/dts/ar9132_tplink_tl-wa901nd-v2.dts131
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk8
3 files changed, 140 insertions, 0 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 6626d99af8..10311bf684 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -18,6 +18,7 @@ ath79_setup_interfaces()
tplink,tl-mr10u|\
tplink,tl-mr3020-v1|\
tplink,tl-mr3040-v2|\
+ tplink,tl-wa901nd-v2|\
tplink,tl-wr703n|\
ubnt,bullet-m|\
ubnt,nanostation-ac-loco|\
diff --git a/target/linux/ath79/dts/ar9132_tplink_tl-wa901nd-v2.dts b/target/linux/ath79/dts/ar9132_tplink_tl-wa901nd-v2.dts
new file mode 100644
index 0000000000..150b76e7a4
--- /dev/null
+++ b/target/linux/ath79/dts/ar9132_tplink_tl-wa901nd-v2.dts
@@ -0,0 +1,131 @@
+// SPDX-License-Identifier: GPL-2.0
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9132.dtsi"
+
+/ {
+ compatible = "tplink,tl-wa901nd-v2", "qca,ar9132";
+ model = "TP-Link TL-WA901ND v2";
+
+ aliases {
+ led-boot = &system;
+ led-failsafe = &system;
+ led-running = &system;
+ led-upgrade = &system;
+ };
+
+ extosc: ref {
+ compatible = "fixed-clock";
+ #clock-cells = <0>;
+ clock-frequency = <40000000>;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ qss {
+ label = "qss";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ system: system {
+ label = "tp-link:green:system";
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ };
+
+ qss {
+ label = "tp-link:green:qss";
+ gpios = <&gpio 4 GPIO_ACTIVE_HIGH>;
+ default-state = "off";
+ };
+
+ wlan {
+ label = "tp-link:green:wlan";
+ gpios = <&gpio 9 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ linux,default-trigger = "phy0tpt";
+ };
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&pll {
+ clocks = <&extosc>;
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@1 {
+ label = "firmware";
+ reg = <0x020000 0x3D0000>;
+ };
+
+ art: partition@2 {
+ label = "art";
+ reg = <0x3F0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy0: ethernet-phy@c {
+ reg = <0xc>;
+ phy-mode = "mii";
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ phy-mode = "mii";
+ mtd-mac-address = <&uboot 0x1fc00>;
+
+ phy-handle = <&phy0>;
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&uboot 0x1fc00>;
+};
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index dadcd24b42..e0c7e283c8 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -51,6 +51,14 @@ define Device/tplink_tl-mr3420-v1
endef
TARGET_DEVICES += tplink_tl-mr3420-v1
+define Device/tplink_tl-wa901nd-v2
+ $(Device/tplink-4m)
+ ATH_SOC := ar9132
+ DEVICE_TITLE := TP-Link TL-WA901ND v2
+ TPLINK_HWID := 0x09010002
+endef
+TARGET_DEVICES += tplink_tl-wa901nd-v2
+
define Device/tplink_tl-wr703n
$(Device/tplink-4mlzma)
ATH_SOC := ar9331