aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-12-08 15:18:17 +0900
committerChristian Lamparter <chunkeey@gmail.com>2018-12-24 19:18:07 +0100
commitc566439c9bf3cf2b4e5e5a059332c64199d97611 (patch)
tree88e55e4b1cbf4911e29df8e7ad31e341882d7aae /target/linux/ath79/image/generic.mk
parent99df98442e1101607e3e6c902d5d957e72cea1d6 (diff)
downloadupstream-c566439c9bf3cf2b4e5e5a059332c64199d97611.tar.gz
upstream-c566439c9bf3cf2b4e5e5a059332c64199d97611.tar.bz2
upstream-c566439c9bf3cf2b4e5e5a059332c64199d97611.zip
ath79: add support for NEC Aterm WG800HP
NEC Aterm WG800HP is a 2.4/5 GHz band 11ac router, based on Qualcomm Atheros QCA9563. Specification: - Qualcomm Atheros QCA9563 - 64 MB of RAM (DDR2) - 8 MB of Flash (SPI-NOR) - 2.4/5 GHz wifi - 2.4 GHz: 2T2R (SoC internal) - 5 GHz: 1T1R (QCA9887) - 4x 10/100/1000 Mbps Ethernet - 8x LEDs, 3x keys (2x buttons, 1x slide-switch) - UART through-hole on PCB (J2) - Vcc, GND, NC, TX, RX from SoC side - 115200n8 Flash instruction using factory image: 1. Connect the computer to the LAN port on WG800HP 2. Connect power cable to WG800HP and turn on it 3. Access to "http://192.168.10.1/" and open firmware update page ("ファームウェア更新") 4. Select the OpenWrt factory image and click update ("更新") button 5. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index c6cecc20d3..badfa7cbab 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -43,6 +43,16 @@ define Build/elecom-header
endef
+define Build/nec-fw
+ ( stat -c%s $@ | tr -d "\n" | dd bs=16 count=1 conv=sync; ) >> $@
+ ( \
+ echo -n -e "$(1)" | dd bs=16 count=1 conv=sync; \
+ echo -n "0.0.00" | dd bs=16 count=1 conv=sync; \
+ dd if=$@; \
+ ) > $@.new
+ mv $@.new $@
+endef
+
define Device/avm_fritz300e
ATH_SOC := ar7242
DEVICE_TITLE := AVM FRITZ!WLAN Repeater 300E
@@ -262,6 +272,19 @@ define Device/iodata_wn-ag300dgr
endef
TARGET_DEVICES += iodata_wn-ag300dgr
+define Device/nec_wg800hp
+ ATH_SOC := qca9563
+ DEVICE_TITLE := NEC Aterm WG800HP
+ IMAGE_SIZE := 7104k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ xor-image -p 6A57190601121E4C004C1E1201061957 -x | \
+ nec-fw LASER_ATERM
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct-htt
+endef
+TARGET_DEVICES += nec_wg800hp
+
define Device/ocedo_koala
ATH_SOC := qca9558
DEVICE_TITLE := OCEDO Koala