aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2020-06-17 00:11:37 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-04 01:09:32 +0100
commitb077accb9c79f215d4da5f44474e72aec07e16dc (patch)
tree2b74c6ef67228d764c5a5826708576c7e5b41aaf /target/linux/ath79/image/generic.mk
parent927b9df938803d409d6b3a47d6834a6c10f68c3d (diff)
downloadupstream-b077accb9c79f215d4da5f44474e72aec07e16dc.tar.gz
upstream-b077accb9c79f215d4da5f44474e72aec07e16dc.tar.bz2
upstream-b077accb9c79f215d4da5f44474e72aec07e16dc.zip
ath79: add support for D-Link DAP-2230 A1
Specifications: * QCA9533, 16 MiB Flash, 64 MiB RAM, 802.11n 2T2R * 10/100 Ethernet Port, 802.11af PoE Installation: * Factory Web UI is at 192.168.0.50 login with 'admin' and blank password, flash factory.bin * Recovery Web UI is at 192.168.0.50 connect network cable, hold reset button during power-on and keep it pressed until uploading has started (only required when checksum is ok, e.g. for reverting back to oem firmware), flash factory.bin After flashing factory.bin, additional free space can be reclaimed by flashing sysupgrade.bin, since the factory image requires some padding to be accepted for upgrading via OEM Web UI. Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ded8e29c2c..080c6a1603 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -749,6 +749,17 @@ define Device/dlink_dap-2xxx
KERNEL_INITRAMFS := $$(KERNEL) | mkwrggimg
endef
+define Device/dlink_dap-2230-a1
+ $(Device/dlink_dap-2xxx)
+ SOC := qca9533
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DAP-2230
+ DEVICE_VARIANT := A1
+ IMAGE_SIZE := 15232k
+ DAP_SIGNATURE := wapn31_dkbs_dap2230
+endef
+TARGET_DEVICES += dlink_dap-2230-a1
+
define Device/dlink_dap-2660-a1
$(Device/dlink_dap-2xxx)
SOC := qca9557