aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-06 12:07:56 +0100
committerMathias Kresin <dev@kresin.me>2018-12-06 13:28:22 +0100
commitdacd962cfd2e7df52d5c711e50863cfc40bf9574 (patch)
tree1b812d2e37a4be6146e87c9755a31df8a85dd12f /target/linux/ath79/image/generic-ubnt.mk
parent9d8fcab77aab6a9133cd6898a68ad512b0b31310 (diff)
downloadupstream-dacd962cfd2e7df52d5c711e50863cfc40bf9574.tar.gz
upstream-dacd962cfd2e7df52d5c711e50863cfc40bf9574.tar.bz2
upstream-dacd962cfd2e7df52d5c711e50863cfc40bf9574.zip
ath79: remove duplicate image build variables
Remove image build variables which are set to the same value as the default image build recipe. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 88be9a78b4..cb65aede5e 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -150,8 +150,6 @@ TARGET_DEVICES += ubnt_unifi
define Device/ubnt_unifiac
ATH_SOC := qca9563
IMAGE_SIZE := 7744k
- IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
endef
@@ -189,7 +187,7 @@ define Device/ubnt_routerstation_common
DEVICE_PACKAGES := -kmod-ath9k -wpad-mini -uboot-envtools kmod-usb-ohci kmod-usb2 fconfig
ATH_SOC := ar7161
IMAGE_SIZE := 16128k
- IMAGES := sysupgrade.bin factory.bin
+ IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | mkubntimage | check-size $$$$(IMAGE_SIZE)
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE) | append-metadata
KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)