aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-06 12:07:56 +0100
committerMathias Kresin <dev@kresin.me>2018-12-06 13:28:22 +0100
commitdacd962cfd2e7df52d5c711e50863cfc40bf9574 (patch)
tree1b812d2e37a4be6146e87c9755a31df8a85dd12f /target/linux/ath79
parent9d8fcab77aab6a9133cd6898a68ad512b0b31310 (diff)
downloadupstream-dacd962cfd2e7df52d5c711e50863cfc40bf9574.tar.gz
upstream-dacd962cfd2e7df52d5c711e50863cfc40bf9574.tar.bz2
upstream-dacd962cfd2e7df52d5c711e50863cfc40bf9574.zip
ath79: remove duplicate image build variables
Remove image build variables which are set to the same value as the default image build recipe. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/image/common-tp-link.mk2
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk2
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk4
-rw-r--r--target/linux/ath79/image/generic.mk12
-rw-r--r--target/linux/ath79/image/nand.mk4
-rw-r--r--target/linux/ath79/image/tiny-netgear.mk4
6 files changed, 9 insertions, 19 deletions
diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index 1dd36ef525..720202de28 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -53,7 +53,7 @@ define Device/tplink
LOADER_TYPE := gz
KERNEL := kernel-bin | append-dtb | lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-v1-header
- IMAGES := sysupgrade.bin factory.bin
+ IMAGES += factory.bin
IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade | append-metadata
IMAGE/factory.bin := append-rootfs | mktplinkfw factory
endef
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index c89198621e..b3f53e7469 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -37,7 +37,7 @@ define Device/tplink_archer-c7-v2
DEVICE_TITLE := TP-LINK Archer C7 v2
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca988x-ct
TPLINK_HWID := 0xc7000002
- IMAGES := sysupgrade.bin factory.bin factory-us.bin factory-eu.bin
+ IMAGES += factory-us.bin factory-eu.bin
IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
endef
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 88be9a78b4..cb65aede5e 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -150,8 +150,6 @@ TARGET_DEVICES += ubnt_unifi
define Device/ubnt_unifiac
ATH_SOC := qca9563
IMAGE_SIZE := 7744k
- IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
endef
@@ -189,7 +187,7 @@ define Device/ubnt_routerstation_common
DEVICE_PACKAGES := -kmod-ath9k -wpad-mini -uboot-envtools kmod-usb-ohci kmod-usb2 fconfig
ATH_SOC := ar7161
IMAGE_SIZE := 16128k
- IMAGES := sysupgrade.bin factory.bin
+ IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | mkubntimage | check-size $$$$(IMAGE_SIZE)
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE) | append-metadata
KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index d5d527fa44..81cdafdd37 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -253,7 +253,6 @@ define Device/pcs_cap324
ATH_SOC := ar9344
DEVICE_TITLE := PowerCloud Systems CAP324
IMAGE_SIZE := 16000k
- IMAGES := sysupgrade.bin
SUPPORTED_DEVICES += cap324
endef
TARGET_DEVICES += pcs_cap324
@@ -262,7 +261,6 @@ define Device/pcs_cr3000
ATH_SOC := ar9341
DEVICE_TITLE := PowerCloud Systems CR3000
IMAGE_SIZE := 7808k
- IMAGES := sysupgrade.bin
SUPPORTED_DEVICES += cr3000
endef
TARGET_DEVICES += pcs_cr3000
@@ -272,7 +270,6 @@ define Device/pcs_cr5000
DEVICE_TITLE := PowerCloud Systems CR5000
DEVICE_PACKAGES := kmod-usb2 kmod-usb-core
IMAGE_SIZE := 7808k
- IMAGES := sysupgrade.bin
SUPPORTED_DEVICES += cr5000
endef
TARGET_DEVICES += pcs_cr5000
@@ -280,7 +277,7 @@ TARGET_DEVICES += pcs_cr5000
define Device/netgear_wndr3x00
ATH_SOC := ar7161
KERNEL := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
- IMAGES := sysupgrade.bin factory.img
+ IMAGES += factory.img
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size $$$$(IMAGE_SIZE)
@@ -316,7 +313,6 @@ define Device/pisen_wmm003n
DEVICE_TITLE := Pisen WMM003N (Cloud Easy Power)
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-chipidea2
TPLINK_HWID := 0x07030101
- IMAGES := sysupgrade.bin
endef
TARGET_DEVICES += pisen_wmm003n
@@ -334,12 +330,8 @@ TARGET_DEVICES += netgear_wndr3800
define Device/phicomm_k2t
ATH_SOC := qca9563
DEVICE_TITLE := Phicomm K2T
- KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
- KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
IMAGE_SIZE := 15744k
- IMAGES := sysupgrade.bin
- IMAGE/default := append-kernel | append-rootfs | pad-rootfs
- IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
DEVICE_PACKAGES := kmod-leds-reset kmod-ath10k-ct ath10k-firmware-qca9888-ct
endef
TARGET_DEVICES += phicomm_k2t
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index e5694b8af4..5c7712308f 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -6,8 +6,8 @@ define Device/glinet_ar300m-nand
BLOCKSIZE := 128k
PAGESIZE := 2048
VID_HDR_OFFSET := 512
- IMAGES := factory.ubi sysupgrade.tar
- IMAGE/sysupgrade.tar := sysupgrade-tar
+ IMAGES += factory.ubi
+ IMAGE/sysupgrade.bin := sysupgrade-tar
IMAGE/factory.ubi := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
TARGET_DEVICES += glinet_ar300m-nand
diff --git a/target/linux/ath79/image/tiny-netgear.mk b/target/linux/ath79/image/tiny-netgear.mk
index 00ed3e8562..8d0de15a1b 100644
--- a/target/linux/ath79/image/tiny-netgear.mk
+++ b/target/linux/ath79/image/tiny-netgear.mk
@@ -10,7 +10,7 @@ define Device/netgear_wnr612-v2
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
NETGEAR_BOARD_ID := REALWNR612V2
IMAGE_SIZE := 3904k
- IMAGES := sysupgrade.bin factory.img
+ IMAGES += factory.img
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size $$$$(IMAGE_SIZE)
@@ -26,7 +26,7 @@ define Device/on_n150r
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
NETGEAR_BOARD_ID := N150R
IMAGE_SIZE := 3904k
- IMAGES := sysupgrade.bin factory.img
+ IMAGES += factory.img
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size $$$$(IMAGE_SIZE)