aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2018-11-26 14:28:00 -0800
committerJohn Crispin <john@phrozen.org>2018-12-03 07:58:56 +0100
commit73127a878dca3da42c35400e2c63a24a2d664088 (patch)
tree2eba7742690489cf1288edfcafc3b2e599771655 /target/linux/ath79/image/generic-ubnt.mk
parent20ec6af15eba161970d95fecbd831e72eb47a56b (diff)
downloadupstream-73127a878dca3da42c35400e2c63a24a2d664088.tar.gz
upstream-73127a878dca3da42c35400e2c63a24a2d664088.tar.bz2
upstream-73127a878dca3da42c35400e2c63a24a2d664088.zip
ath79: add support for Ubiquiti AirRouter
Indoor low-power router with 2.4 GHz radio CPU: Atheros AR7241 rev 1 RAM: 32 MB Flash: 8 MB NOR SPI Switch: Atheros AR7240 Ports: 1x WAN, 4x LAN 10/100 Ethernet WLAN: Atheros AR9285 (2.4 GHz) USB: 1x USB2 host port Note: Ethernet WAN/LAN port naming is reversed from ar71xx. WAN is eth0; LAN is eth1.1. UART settings: 115200, 8N1 LEDs +-------------------------- | | | | | | | | VCC | x x RX | * x | x x | x x TX | * x GND | * x | | | | +-------------------------- ETHERNET PORTS Installation from Ubiquiti firmware, is as for other ubnt-xm AirOs devices. Signed-off-by: Russell Senior <russell@personaltelco.net>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 66c16e44b0..88be9a78b4 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -78,6 +78,13 @@ define Device/ubnt-xw
ATH_SOC := ar9342
endef
+define Device/ubnt_airrouter
+ $(Device/ubnt-xm)
+ DEVICE_TITLE := Ubiquiti AirRouter
+ SUPPORTED_DEVICES += airrouter
+endef
+TARGET_DEVICES += ubnt_airrouter
+
define Device/ubnt_bullet-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Bullet-M