aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2018-11-26 14:28:00 -0800
committerJohn Crispin <john@phrozen.org>2018-12-03 07:58:56 +0100
commit73127a878dca3da42c35400e2c63a24a2d664088 (patch)
tree2eba7742690489cf1288edfcafc3b2e599771655 /target/linux/ath79
parent20ec6af15eba161970d95fecbd831e72eb47a56b (diff)
downloadupstream-73127a878dca3da42c35400e2c63a24a2d664088.tar.gz
upstream-73127a878dca3da42c35400e2c63a24a2d664088.tar.bz2
upstream-73127a878dca3da42c35400e2c63a24a2d664088.zip
ath79: add support for Ubiquiti AirRouter
Indoor low-power router with 2.4 GHz radio CPU: Atheros AR7241 rev 1 RAM: 32 MB Flash: 8 MB NOR SPI Switch: Atheros AR7240 Ports: 1x WAN, 4x LAN 10/100 Ethernet WLAN: Atheros AR9285 (2.4 GHz) USB: 1x USB2 host port Note: Ethernet WAN/LAN port naming is reversed from ar71xx. WAN is eth0; LAN is eth1.1. UART settings: 115200, 8N1 LEDs +-------------------------- | | | | | | | | VCC | x x RX | * x | x x | x x TX | * x GND | * x | | | | +-------------------------- ETHERNET PORTS Installation from Ubiquiti firmware, is as for other ubnt-xm AirOs devices. Signed-off-by: Russell Senior <russell@personaltelco.net>
Diffstat (limited to 'target/linux/ath79')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom1
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_airrouter.dts38
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk7
4 files changed, 48 insertions, 1 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index b9d6c709e7..d79ba04a44 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -124,7 +124,8 @@ ath79_setup_interfaces()
buffalo,whr-g301n|\
tplink,tl-mr3220-v1|\
tplink,tl-mr3420-v1|\
- tplink,tl-wr841-v7)
+ tplink,tl-wr841-v7|\
+ ubnt,airrouter)
ucidef_set_interface_wan "eth0"
ucidef_add_switch "switch0" \
"0@eth1" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index 020abe2913..68f70174bb 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -141,6 +141,7 @@ case "$FIRMWARE" in
tplink,tl-wr741-v1|\
tplink,tl-wr743nd-v1|\
tplink,tl-wr841-v7|\
+ ubnt,airrouter|\
ubnt,bullet-m|\
ubnt,nano-m|\
ubnt,rocket-m)
diff --git a/target/linux/ath79/dts/ar7241_ubnt_airrouter.dts b/target/linux/ath79/dts/ar7241_ubnt_airrouter.dts
new file mode 100644
index 0000000000..fbe289f05a
--- /dev/null
+++ b/target/linux/ath79/dts/ar7241_ubnt_airrouter.dts
@@ -0,0 +1,38 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar7241_ubnt_xm.dtsi"
+
+/ {
+ compatible = "ubnt,airrouter", "qca,ar7241";
+ model = "Ubiquiti AirRouter";
+
+ aliases {
+ led-boot = &globe;
+ led-failsafe = &globe;
+ led-running = &globe;
+ led-upgrade = &globe;
+ };
+
+ airrouter-leds {
+ compatible = "gpio-leds";
+
+ globe: globe {
+ label = "ubnt:green:globe";
+ gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+ };
+
+ power {
+ label = "ubnt:green:power";
+ gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+ };
+ };
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&usb {
+ status = "okay";
+};
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 66c16e44b0..88be9a78b4 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -78,6 +78,13 @@ define Device/ubnt-xw
ATH_SOC := ar9342
endef
+define Device/ubnt_airrouter
+ $(Device/ubnt-xm)
+ DEVICE_TITLE := Ubiquiti AirRouter
+ SUPPORTED_DEVICES += airrouter
+endef
+TARGET_DEVICES += ubnt_airrouter
+
define Device/ubnt_bullet-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Bullet-M