aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-03-25 18:46:26 +0100
committerPetr Štetiar <ynezz@true.cz>2019-04-02 02:10:59 +0200
commit141698ce8fbc52d253c9207ef46b3630a0870567 (patch)
tree8226c8567b438f718199ed4c416d06945b8fd672 /target/linux/ath79/image/generic-tp-link.mk
parent5ec205d7ac00de89510a6e71055d45aa57b705e1 (diff)
downloadupstream-141698ce8fbc52d253c9207ef46b3630a0870567.tar.gz
upstream-141698ce8fbc52d253c9207ef46b3630a0870567.tar.bz2
upstream-141698ce8fbc52d253c9207ef46b3630a0870567.zip
ath79: Add support for TP-Link CPE210 v2
This PR adds support for a popular low-cost 2.4GHz N based AP Specifications: - SoC: Qualcomm Atheros QCA9533 (650MHz) - RAM: 64MB - Storage: 8 MB SPI NOR - Wireless: 2.4GHz N based built into SoC 2x2 - Ethernet: 1x 100/10 Mbps, integrated into SoC, 24V POE IN Installation: Flash factory image through stock firmware WEB UI or through TFTP To get to TFTP recovery just hold reset button while powering on for around 4-5 seconds and release. Rename factory image to recovery.bin Stock TFTP server IP:192.168.0.100 Stock device TFTP adress:192.168.0.254 This is based on the support patch for the identical CPE210 v3 by Mario Schroen <m.schroen@web.de>. Tested-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> [renamed dtsi filename] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 92d811f10b..e3a0abeb5f 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -109,6 +109,19 @@ define Device/tplink_archer-c7-v5
endef
TARGET_DEVICES += tplink_archer-c7-v5
+define Device/tplink_cpe210-v2
+ $(Device/tplink-safeloader)
+ ATH_SOC := qca9533
+ IMAGE_SIZE := 7680k
+ DEVICE_TITLE := TP-Link CPE210 v2
+ TPLINK_BOARD_ID := CPE210V2
+ DEVICE_PACKAGES := rssileds
+ LOADER_TYPE := elf
+ KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
+ SUPPORTED_DEVICES += cpe210-v2
+endef
+TARGET_DEVICES += tplink_cpe210-v2
+
define Device/tplink_cpe210-v3
$(Device/tplink-safeloader)
ATH_SOC := qca9533