aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorMario Schroen <m.schroen@web.de>2019-03-31 21:07:03 +0200
committerPetr Štetiar <ynezz@true.cz>2019-04-02 02:10:59 +0200
commit5ec205d7ac00de89510a6e71055d45aa57b705e1 (patch)
tree950387166b672b140d060c5c72ae47b7bc9434be /target/linux/ath79/image/generic-tp-link.mk
parent99f6f2c0b8cbeb0c6ba464e080ab039984444f1f (diff)
downloadupstream-5ec205d7ac00de89510a6e71055d45aa57b705e1.tar.gz
upstream-5ec205d7ac00de89510a6e71055d45aa57b705e1.tar.bz2
upstream-5ec205d7ac00de89510a6e71055d45aa57b705e1.zip
ath79: Add support for TP-Link CPE210 v3
Specifications: * SoC: Qualcomm Atheros QCA9533 (650MHz) * RAM: 64MB * Storage: 8 MB SPI NOR * Wireless: 2.4GHz N based built into SoC 2x2 * Ethernet: 1x 100/10 Mbps, integrated into SoC, 24V POE IN Installation: Flash factory image through stock firmware WEB UI or TFTP To get to TFTP recovery just hold reset button while powering on for around 4-5 seconds and release. Rename factory image to recovery.bin Stock TFTP server IP:192.168.0.100 Stock device TFTP adress:192.168.0.254 Thanks to robimarko for the work inside the ar71xx tree. Thanks to adrianschmutzler for deep discussion and fixes. Signed-off-by: Mario Schroen <m.schroen@web.de> [Split into DTS/DTSI, read-only config partition in DTSI] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> [renamed dtsi filename, light subject touches] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 19a156be79..92d811f10b 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -109,6 +109,19 @@ define Device/tplink_archer-c7-v5
endef
TARGET_DEVICES += tplink_archer-c7-v5
+define Device/tplink_cpe210-v3
+ $(Device/tplink-safeloader)
+ ATH_SOC := qca9533
+ IMAGE_SIZE := 7680k
+ DEVICE_TITLE := TP-Link CPE210 v3
+ DEVICE_PACKAGES := rssileds
+ TPLINK_BOARD_ID := CPE210V3
+ LOADER_TYPE := elf
+ KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
+ SUPPORTED_DEVICES += cpe210-v3
+endef
+TARGET_DEVICES += tplink_cpe210-v3
+
define Device/tplink_re350k-v1
$(Device/tplink)
ATH_SOC := qca9558