aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-tp-link.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-10-31 20:19:49 +0100
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:45 +0100
commit946ffe470d923fdde53db68592437194e0c276fc (patch)
tree2c58bfacae446fcb27ef3ac05d68254dab0c6b68 /target/linux/ath79/image/common-tp-link.mk
parent89eb1a6d7250c33ff5b43f4af3c0c78ffd3d8eb9 (diff)
downloadupstream-946ffe470d923fdde53db68592437194e0c276fc.tar.gz
upstream-946ffe470d923fdde53db68592437194e0c276fc.tar.bz2
upstream-946ffe470d923fdde53db68592437194e0c276fc.zip
ath79: add support for Archer C58/C59 v1
This commit adds support for the Archer C58 v1 and C59 v1, previously supported in the ar71xx target. CPU: Qualcomm QCA9561 RAM: 64M (C58) / 128M (C59) FLASH: 8M (C58) / 16M (C59) WiFi: QCA9561 bgn 3x3:3 QCA9888 nac 2x2:2 LED: Power, WiFi 2.4, WiFi 5, WAN green, WAN amber, LAN, WPS Only C59: USB BTN: WPS, WiFi, Reset Installation ------------ Via Web-UI: Update factory image via Web-UI. Via TFTP: Rename factory image to "tp_recovery.bin" and place it in the root-dir of your tftp server. Configure to listen on 192.168.0.66. Power up the router while holding down the reset-button. The router will flash itself and reboot. Note: For TFTP, you might need a switch between router and computer, as link establishment might take to long. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/common-tp-link.mk')
-rw-r--r--target/linux/ath79/image/common-tp-link.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index 7490aeb1f3..1dd36ef525 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -39,6 +39,14 @@ define Build/mktplinkfw-combined
@mv $@.new $@
endef
+define Build/uImageArcher
+ mkimage -A $(LINUX_KARCH) \
+ -O linux -T kernel \
+ -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
+ @mv $@.new $@
+endef
+
define Device/tplink
TPLINK_HWREV := 0x1
TPLINK_HEADER_VERSION := 1
@@ -88,3 +96,15 @@ define Device/tplink-16mlzma
TPLINK_FLASHLAYOUT := 16Mlzma
IMAGE_SIZE := 15872k
endef
+
+define Device/tplink-safeloader
+ $(Device/tplink)
+ KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | append-metadata
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+
+define Device/tplink-safeloader-uimage
+ $(Device/tplink-safeloader)
+ KERNEL := kernel-bin | append-dtb | lzma | uImageArcher lzma
+endef