aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-10-31 20:19:49 +0100
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:45 +0100
commit946ffe470d923fdde53db68592437194e0c276fc (patch)
tree2c58bfacae446fcb27ef3ac05d68254dab0c6b68 /target/linux/ath79
parent89eb1a6d7250c33ff5b43f4af3c0c78ffd3d8eb9 (diff)
downloadupstream-946ffe470d923fdde53db68592437194e0c276fc.tar.gz
upstream-946ffe470d923fdde53db68592437194e0c276fc.tar.bz2
upstream-946ffe470d923fdde53db68592437194e0c276fc.zip
ath79: add support for Archer C58/C59 v1
This commit adds support for the Archer C58 v1 and C59 v1, previously supported in the ar71xx target. CPU: Qualcomm QCA9561 RAM: 64M (C58) / 128M (C59) FLASH: 8M (C58) / 16M (C59) WiFi: QCA9561 bgn 3x3:3 QCA9888 nac 2x2:2 LED: Power, WiFi 2.4, WiFi 5, WAN green, WAN amber, LAN, WPS Only C59: USB BTN: WPS, WiFi, Reset Installation ------------ Via Web-UI: Update factory image via Web-UI. Via TFTP: Rename factory image to "tp_recovery.bin" and place it in the root-dir of your tftp server. Configure to listen on 192.168.0.66. Power up the router while holding down the reset-button. The router will flash itself and reboot. Note: For TFTP, you might need a switch between router and computer, as link establishment might take to long. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds5
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata6
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac4
-rw-r--r--target/linux/ath79/dts/qca9561_tplink_archer-c58-v1.dts130
-rw-r--r--target/linux/ath79/dts/qca9561_tplink_archer-c59-v1.dts153
-rw-r--r--target/linux/ath79/dts/qca9561_tplink_archer-c5x.dtsi98
-rw-r--r--target/linux/ath79/image/common-tp-link.mk20
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk22
9 files changed, 441 insertions, 1 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 47c900f6eb..7945ecba1f 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -52,6 +52,11 @@ pcs,cr3000)
ucidef_set_led_switch "lan3" "LAN3" "pcs:blue:lan3" "switch0" "0x10"
ucidef_set_led_switch "lan4" "LAN4" "pcs:blue:lan4" "switch0" "0x02"
;;
+tplink,archer-c58-v1|\
+tplink,archer-c59-v1)
+ ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x1E"
+ ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth0"
+ ;;
tplink,re450-v2)
ucidef_set_led_netdev "lan_data" "LAN Data" "tp-link:green:lan_data" "eth0" "tx rx"
ucidef_set_led_netdev "lan_link" "LAN Link" "tp-link:green:lan_link" "eth0" "link"
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index fca9e42fb5..6aca7c7899 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -32,7 +32,9 @@ ath79_setup_interfaces()
wd,mynet-wifi-rangeextender)
ucidef_set_interface_lan "eth0"
;;
- avm,fritz4020)
+ avm,fritz4020|\
+ tplink,archer-c58-v1|\
+ tplink,archer-c59-v1)
ucidef_set_interface_wan "eth0"
ucidef_add_switch "switch0" \
"0@eth1" "1:lan:1" "2:lan:4" "3:lan:3" "4:lan:2"
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index b4bc20d1cf..cbc5c96170 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -131,6 +131,12 @@ case "$FIRMWARE" in
ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
/lib/firmware/ath10k/QCA9888/hw2.0/board.bin
;;
+ tplink,archer-c58-v1|\
+ tplink,archer-c59-v1)
+ ath10kcal_extract "art" 20480 12064
+ ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
+ /lib/firmware/ath10k/QCA9888/hw2.0/board.bin
+ ;;
esac
;;
*)
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac b/target/linux/ath79/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
index 59c58f9c67..fe5aa64a19 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
+++ b/target/linux/ath79/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
@@ -18,6 +18,10 @@ case "$board" in
[ "$PHYNBR" -eq 1 ] && \
echo $(k2t_get_mac "lan_mac") > /sys${DEVPATH}/macaddress
;;
+ tplink,archer-c58-v1|\
+ tplink,archer-c59-v1)
+ echo $(macaddr_add $(mtd_get_mac_binary mac 8) $(($PHYNBR - 1)) ) > /sys${DEVPATH}/macaddress
+ ;;
*)
;;
esac
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c58-v1.dts b/target/linux/ath79/dts/qca9561_tplink_archer-c58-v1.dts
new file mode 100644
index 0000000000..ffce955fd3
--- /dev/null
+++ b/target/linux/ath79/dts/qca9561_tplink_archer-c58-v1.dts
@@ -0,0 +1,130 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9561_tplink_archer-c5x.dtsi"
+
+/ {
+ compatible = "tplink,archer-c58-v1", "qca,qca9560";
+ model = "TP-LINK Archer C58 v1";
+
+ aliases {
+ led-boot = &power;
+ led-failsafe = &power;
+ led-running = &power;
+ led-upgrade = &power;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ power: power {
+ label = "tp-link:green:power";
+ gpios = <&led_gpio 0 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wlan2g {
+ label = "tp-link:green:wlan2g";
+ gpios = <&led_gpio 1 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ default-state = "off";
+ };
+
+ wlan5g {
+ label = "tp-link:green:wlan5g";
+ gpios = <&led_gpio 2 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ default-state = "off";
+ };
+
+ wan_green {
+ label = "tp-link:green:wan";
+ gpios = <&led_gpio 4 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ wan_amber {
+ label = "tp-link:amber:wan";
+ gpios = <&led_gpio 5 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ lan {
+ label = "tp-link:green:lan";
+ gpios = <&led_gpio 3 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ wps {
+ label = "tp-link:green:wps";
+ gpios = <&led_gpio 6 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+ };
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x010000>;
+ read-only;
+ };
+
+ mac: partition@10000 {
+ label = "mac";
+ reg = <0x010000 0x010000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "firmware";
+ reg = <0x020000 0x7c0000>;
+ };
+
+ partition@7e0000 {
+ label = "tplink";
+ reg = <0x7e0000 0x010000>;
+ read-only;
+ };
+
+ art: partition@7f0000 {
+ label = "art";
+ reg = <0x7f0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&eth0 {
+ status = "okay";
+ mtd-mac-address = <&mac 0x8>;
+ mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+ status = "okay";
+ mtd-mac-address = <&mac 0x8>;
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&mac 0x8>;
+};
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c59-v1.dts b/target/linux/ath79/dts/qca9561_tplink_archer-c59-v1.dts
new file mode 100644
index 0000000000..9d4df9a5fc
--- /dev/null
+++ b/target/linux/ath79/dts/qca9561_tplink_archer-c59-v1.dts
@@ -0,0 +1,153 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9561_tplink_archer-c5x.dtsi"
+
+/ {
+ compatible = "tplink,archer-c59-v1", "qca,qca9560";
+ model = "TP-LINK Archer C59 v1";
+
+ aliases {
+ led-boot = &power;
+ led-failsafe = &power;
+ led-running = &power;
+ led-upgrade = &power;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ power: power {
+ label = "tp-link:green:power";
+ gpios = <&led_gpio 0 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wlan2g {
+ label = "tp-link:green:wlan2g";
+ gpios = <&led_gpio 1 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ default-state = "off";
+ };
+
+ wlan5g {
+ label = "tp-link:green:wlan5g";
+ gpios = <&led_gpio 2 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ default-state = "off";
+ };
+
+ wan_green {
+ label = "tp-link:green:wan";
+ gpios = <&led_gpio 4 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ wan_amber {
+ label = "tp-link:amber:wan";
+ gpios = <&led_gpio 5 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ lan {
+ label = "tp-link:green:lan";
+ gpios = <&led_gpio 3 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ wps {
+ label = "tp-link:green:wps";
+ gpios = <&led_gpio 6 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ usb {
+ label = "tp-link:green:usb";
+ gpios = <&led_gpio 7 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ linux,default-trigger = "usbport";
+ trigger-sources = <&hub_port>;
+ };
+ };
+};
+
+&usb0 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ hub_port: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
+};
+
+&usb_phy0 {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x010000>;
+ read-only;
+ };
+
+ mac: partition@10000 {
+ label = "mac";
+ reg = <0x010000 0x010000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "firmware";
+ reg = <0x020000 0xe30000>;
+ };
+
+ partition@e50000 {
+ label = "tplink";
+ reg = <0xe50000 0x1a0000>;
+ read-only;
+ };
+
+ art: partition@ff0000 {
+ label = "art";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&eth0 {
+ status = "okay";
+ mtd-mac-address = <&mac 0x8>;
+ mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+ status = "okay";
+ mtd-mac-address = <&mac 0x8>;
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&mac 0x8>;
+};
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c5x.dtsi b/target/linux/ath79/dts/qca9561_tplink_archer-c5x.dtsi
new file mode 100644
index 0000000000..dc56bf682a
--- /dev/null
+++ b/target/linux/ath79/dts/qca9561_tplink_archer-c5x.dtsi
@@ -0,0 +1,98 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+ compatible = "tplink,archer-c5x", "qca,qca9560";
+
+ chosen {
+ bootargs = "console=ttyS0,115200n8";
+ };
+
+ led_spi {
+ compatible = "spi-gpio";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ gpio-sck = <&gpio 18 GPIO_ACTIVE_HIGH>;
+ gpio-mosi = <&gpio 17 GPIO_ACTIVE_HIGH>;
+ cs-gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;
+ num-chipselects = <1>;
+
+ led_gpio: led_gpio@0 {
+ compatible = "fairchild,74hc595";
+ reg = <0>;
+ gpio-controller;
+ #gpio-cells = <2>;
+ registers-number = <1>;
+ spi-max-frequency = <10000000>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <100>;
+
+ wps_button {
+ label = "WPS button";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi_button {
+ label = "WiFi button";
+ linux,code = <KEY_RFKILL>;
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ };
+
+ reset_button {
+ label = "Reset button";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ gpio-export {
+ compatible = "gpio-export";
+
+ gpio_shift_register_oe {
+ gpio-export,name = "tp-link:oe:sr";
+ gpio-export,output = <0>;
+ gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
+ };
+
+ gpio_shift_register_reset {
+ gpio-export,name = "tp-link:reset:sr";
+ gpio-export,output = <1>;
+ gpios = <&gpio 19 GPIO_ACTIVE_HIGH>;
+ };
+
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&gpio {
+ status = "okay";
+};
+
+&pcie {
+ status = "okay";
+};
+
+&eth0 {
+ phy-mode = "mii";
+ phy-handle = <&swphy0>;
+
+ gmac-config {
+ device = <&gmac>;
+
+ switch-phy-addr-swap = <1>;
+ switch-phy-swap = <1>;
+ };
+};
diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index 7490aeb1f3..1dd36ef525 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -39,6 +39,14 @@ define Build/mktplinkfw-combined
@mv $@.new $@
endef
+define Build/uImageArcher
+ mkimage -A $(LINUX_KARCH) \
+ -O linux -T kernel \
+ -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
+ @mv $@.new $@
+endef
+
define Device/tplink
TPLINK_HWREV := 0x1
TPLINK_HEADER_VERSION := 1
@@ -88,3 +96,15 @@ define Device/tplink-16mlzma
TPLINK_FLASHLAYOUT := 16Mlzma
IMAGE_SIZE := 15872k
endef
+
+define Device/tplink-safeloader
+ $(Device/tplink)
+ KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | append-metadata
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+
+define Device/tplink-safeloader-uimage
+ $(Device/tplink-safeloader)
+ KERNEL := kernel-bin | append-dtb | lzma | uImageArcher lzma
+endef
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index d65e29e72a..c89198621e 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -1,5 +1,27 @@
include ./common-tp-link.mk
+define Device/tplink_archer-c58-v1
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9561
+ IMAGE_SIZE := 7936k
+ DEVICE_TITLE := TP-LINK Archer C58 v1
+ TPLINK_BOARD_ID := ARCHER-C58-V1
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+ SUPPORTED_DEVICES += archer-c58-v1
+endef
+TARGET_DEVICES += tplink_archer-c58-v1
+
+define Device/tplink_archer-c59-v1
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9561
+ IMAGE_SIZE := 14528k
+ DEVICE_TITLE := TP-LINK Archer C59 v1
+ TPLINK_BOARD_ID := ARCHER-C59-V1
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca9888-ct
+ SUPPORTED_DEVICES += archer-c59-v1
+endef
+TARGET_DEVICES += tplink_archer-c59-v1
+
define Device/tplink_archer-c7-v1
$(Device/tplink-8mlzma)
ATH_SOC := qca9558