aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-netgear.mk
diff options
context:
space:
mode:
authorDaniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>2018-09-13 21:08:51 -0700
committerPetr Štetiar <ynezz@true.cz>2019-04-09 11:09:26 +0200
commitf61e754522996d1557691f945518b69a14d0446c (patch)
tree1dac436c2947895045fd0ce654785a2170701ce9 /target/linux/ath79/image/common-netgear.mk
parentd75d4837fc714284042210f0704cf495f0d0c956 (diff)
downloadupstream-f61e754522996d1557691f945518b69a14d0446c.tar.gz
upstream-f61e754522996d1557691f945518b69a14d0446c.tar.bz2
upstream-f61e754522996d1557691f945518b69a14d0446c.zip
ath79: add support for Netgear EX6400 and EX7300
This is sold as a dual-band 802.11ac range extender. It has a sliding switch for Extender mode or Access Point mode, a WPS button, a recessed Reset button, a hard-power button, and a multitude of LED's, some multiplexed via an NXP 74AHC164D chip. The internal serial header pinout is Vcc, Tx, Rx, GND, with GND closest to the corner of the board. You may connect at 115200 bps, 8 data bits, no parity, 1 stop bit. Specification: - System-On-Chip: QCA9558 - CPU/Speed: 720 MHz - Flash-Chip: Winbond 25Q128FVSG - Flash size: 16 MiB - RAM: 128 MiB - Wireless No1: QCA9558 on-chip 2.4GHz 802.11bgn, 3x3 - Wireless No2: QCA99x0 chip 5GHz 802.11an+ac, 4x4 - PHY: Atheros AR8035-A Installation: If you can get to the stock firmware's firmware upgrade option, just feed it the factory.img and boot as usual. As an alternative, TFTP the factory.img to the bootloader. Signed-off-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us> [whitespace fix in DTS and reorder of make variables] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/common-netgear.mk')
-rw-r--r--target/linux/ath79/image/common-netgear.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/common-netgear.mk b/target/linux/ath79/image/common-netgear.mk
index 956266ab2c..9b79936295 100644
--- a/target/linux/ath79/image/common-netgear.mk
+++ b/target/linux/ath79/image/common-netgear.mk
@@ -19,6 +19,16 @@ define Build/netgear-squashfs
rm -rf $@.squashfs $@.fs
endef
+define Build/netgear-rootfs
+ mkimage \
+ -A mips -O linux -T filesystem -C none \
+ -M $(NETGEAR_KERNEL_MAGIC) \
+ -n '$(VERSION_DIST) filesystem' \
+ -d $(IMAGE_ROOTFS) $@.fs
+ cat $@.fs >> $@
+ rm -rf $@.fs
+endef
+
define Build/netgear-uImage
$(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
endef