aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-netgear.mk
diff options
context:
space:
mode:
authorDaniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>2019-01-02 14:19:04 -0800
committerPetr Štetiar <ynezz@true.cz>2019-04-09 11:09:26 +0200
commitd75d4837fc714284042210f0704cf495f0d0c956 (patch)
treeff80464a180f9db66fe3051e57142edbbb48fbd1 /target/linux/ath79/image/common-netgear.mk
parent1f839c85840df4b565c95a63adf0d428501bcb48 (diff)
downloadupstream-d75d4837fc714284042210f0704cf495f0d0c956.tar.gz
upstream-d75d4837fc714284042210f0704cf495f0d0c956.tar.bz2
upstream-d75d4837fc714284042210f0704cf495f0d0c956.zip
ath79: remove more duplicate image build variables
Remove Netgear-specific image build variables which are set to the same value. Signed-off-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us> [reordering of variables, removed stray newline] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/common-netgear.mk')
-rw-r--r--target/linux/ath79/image/common-netgear.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ath79/image/common-netgear.mk b/target/linux/ath79/image/common-netgear.mk
index 5dfcd38a92..956266ab2c 100644
--- a/target/linux/ath79/image/common-netgear.mk
+++ b/target/linux/ath79/image/common-netgear.mk
@@ -22,3 +22,10 @@ endef
define Build/netgear-uImage
$(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
endef
+
+define Device/netgear_ath79
+ KERNEL := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
+ IMAGES += factory.img
+ IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size $$$$(IMAGE_SIZE)
+endef