aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/mikrotik/profiles/00-default.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-07 20:54:42 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-16 20:40:12 +0100
commit0e547400fbcc4b6610d3b810f123d4963f9b2ea7 (patch)
tree02c77973422043aacdb35e3fc313c2a18667a542 /target/linux/ar71xx/mikrotik/profiles/00-default.mk
parenta8a5cb9595cd64a48c1cea6a1478c11e022474a9 (diff)
downloadupstream-0e547400fbcc4b6610d3b810f123d4963f9b2ea7.tar.gz
upstream-0e547400fbcc4b6610d3b810f123d4963f9b2ea7.tar.bz2
upstream-0e547400fbcc4b6610d3b810f123d4963f9b2ea7.zip
ar71xx: create a proper default profile for the mikrotik subtarget, drop other profiles
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx/mikrotik/profiles/00-default.mk')
-rw-r--r--target/linux/ar71xx/mikrotik/profiles/00-default.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/mikrotik/profiles/00-default.mk b/target/linux/ar71xx/mikrotik/profiles/00-default.mk
new file mode 100644
index 0000000000..f3dfeef7bd
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/profiles/00-default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport nand-utils
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))