aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-07 20:54:42 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-16 20:40:12 +0100
commit0e547400fbcc4b6610d3b810f123d4963f9b2ea7 (patch)
tree02c77973422043aacdb35e3fc313c2a18667a542 /target
parenta8a5cb9595cd64a48c1cea6a1478c11e022474a9 (diff)
downloadupstream-0e547400fbcc4b6610d3b810f123d4963f9b2ea7.tar.gz
upstream-0e547400fbcc4b6610d3b810f123d4963f9b2ea7.tar.bz2
upstream-0e547400fbcc4b6610d3b810f123d4963f9b2ea7.zip
ar71xx: create a proper default profile for the mikrotik subtarget, drop other profiles
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/mikrotik/profiles/00-default.mk (renamed from target/linux/ar71xx/mikrotik/profiles/01-minimal.mk)12
-rw-r--r--target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk17
2 files changed, 6 insertions, 23 deletions
diff --git a/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk b/target/linux/ar71xx/mikrotik/profiles/00-default.mk
index a334977d48..f3dfeef7bd 100644
--- a/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
+++ b/target/linux/ar71xx/mikrotik/profiles/00-default.mk
@@ -5,13 +5,13 @@
# See /LICENSE for more information.
#
-define Profile/DefaultNoWifi
- NAME:=Default Profile (no WiFi)
- PACKAGES:=
- PRIORITY := 2
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport nand-utils
endef
-define Profile/DefaultNoWifi/Description
+define Profile/Default/Description
Default package set compatible with most boards.
endef
-$(eval $(call Profile,DefaultNoWifi))
+$(eval $(call Profile,Default))
diff --git a/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk b/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
deleted file mode 100644
index fa304b7d4c..0000000000
--- a/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Ath5k
- NAME:=Atheros WiFi (ath5k)
- PACKAGES:=kmod-ath5k -kmod-ath9k
- PRIORITY := 3
-endef
-
-define Profile/Ath5k/Description
- Package set compatible with hardware using Atheros WiFi cards.
-endef
-$(eval $(call Profile,Ath5k))